Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#1514 closed defect (invalid)

Minor torrc parsing bug

Reported by: atagar Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.1.20
Severity: Keywords: torrc exitpolicy tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Very minor bug with, I'm guessing, torrc parsing.

Steps to repro:

  1. In your torrc include "ExitPolicy" without a policy among other entries, ex:

ExitPolicy
ExitPolicy reject *:*

  1. Start tor, these values are excepted without issue.
  1. Query the ExitPolicy via the control port (GETCONF ExitPolicy)

Results:
Whenever the exit policy is queried the following warning is given
May 26 21:27:12.815 [warn] The abbreviation 'ExitPolic' is deprecated. Please use 'ExitPolicy' instead

Oddly, this warning is only shown at the command line (ie, doesn't seem to be provided to listening controllers).

Child Tickets

Change History (5)

comment:1 Changed 10 years ago by cypherpunks

I can't reproduce. Perhaps the wiki formatting is screwing up your bug report.

I set two lines in my torrc:

ExitPolicy
ExitPolicy reject *:*

Then I start tor, and do a getconf exitpolicy

I get:

250-ExitPolicy=reject *:*
250 ExitPolicy=reject *:*

which is kind of unusual, but not that shocking. Also not what you reported.

More details?

comment:2 Changed 10 years ago by atagar

Those are the right repro steps. If tor isn't logging a warning to the terminal then this issue isn't occurring for you. If so this can be closed (might then just be a version issue).

comment:3 Changed 10 years ago by atagar

Resolution: invalid
Status: newclosed

My bad, this was an arm issue (was calling GETCONF when trying to validate the torrc and truncating the command... oops). Resolving.

comment:4 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:5 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.