Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1518 closed defect (worksforme)

EntryStatistics config option breaks Tor

Reported by: Falo Owned by: karsten
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.12-alpha
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Two and a half days after enabling entry statistics with config option "EntryStatistics 1" in one of my four Tor process its error logging started and traffic dropped nearly to zero. Since I've never seen this error before I suppose this problem being related to EntryStatistics config option.

May 30 06:25:04.428 [warn] couldn't find end of hashed material "
router-signature"
May 30 06:25:04.428 [warn] router_rebuild_descriptor(): Bug: Couldn't generate extra-info descriptor.
May 30 06:25:04.448 [warn] couldn't find end of hashed material "
router-signature"
May 30 06:25:04.448 [warn] router_rebuild_descriptor(): Bug: Couldn't generate extra-info descriptor.
May 30 06:25:04.475 [warn] couldn't find end of hashed material "
router-signature"
May 30 06:25:04.475 [warn] router_rebuild_descriptor(): Bug: Couldn't generate extra-info descriptor.
May 30 06:25:06.505 [warn] couldn't find end of hashed material "
router-signature"
May 30 06:25:06.505 [warn] router_rebuild_descriptor(): Bug: Couldn't generate extra-info descriptor.

Child Tickets

Change History (12)

comment:1 Changed 9 years ago by Falo

Component: Tor-Tor clientTor-Tor server

hmm, I had to remove stats/dirreq-stats to get Tor up and running again. Removing stats/entry-stats file didn't help.

comment:2 Changed 9 years ago by karsten

Can you paste your stats/dirreq-stats here? (It's not secret, but would have been included in the extra-info descriptor anyway.)

comment:3 Changed 9 years ago by Falo

I'm sorry, stupidly I didn't back up the dirreq-stats file unlike I did with entry-stats before. Thus I propose to leave this ticket open until the bug hits again and the next time I won't burn the corpse before autopsy.

comment:4 Changed 9 years ago by Falo

and here we go. I did an upgrade to the most recent version 0.2.2.13-alpha and today the bug hits again. EntryStatistics, ExitPortStatistics, and DirReqStatistics are enabled in torrc. The bug did never hit before without having EntryStatistics enabled even it appears to be DirReqStatistics related since removing stats/dirreq-stats from filesystem make Tor work again.

You'll find the stats directory here:
http://selke.de/pics/ticket-1518-stats.tar.gz

comment:5 Changed 9 years ago by karsten

Owner: set to karsten
Status: newassigned

Interesting. The files look normal to me, except one thing:

dirreq-v2-share 0.00%
dirreq-v3-share 0.00%

As a directory mirror you should see more than 0.00% of all network status requests.

I also took a look at the other reported dirreq-stats. blutmagie has stopped reporting dirreq-stats after May 28, and both vallenator and trusted seem to think that they don't see any directory requests from May 29 on. Last column in these lines is the dirreq-share:

vallenator
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-20,16,40,16,8,288,16,144,24,0,64,8,80,16,0.78
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-21,8,32,8,8,208,8,120,32,0,48,8,64,8,0.51
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-22,16,48,16,8,320,8,112,32,0,48,8,64,8,0.85
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-23,16,56,8,8,336,16,120,32,0,64,8,56,8,0.77
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-24,16,48,8,0,288,16,120,24,0,48,8,32,8,0.72
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-25,24,48,8,8,400,8,136,40,0,80,8,72,16,0.67
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-26,16,48,16,8,400,24,136,40,0,72,8,88,8,0.88
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-27,16,56,16,16,408,16,168,40,0,88,8,88,8,0.24
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-28,16,64,16,8,328,8,160,48,8,104,8,88,8,0.11
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-29,16,56,24,8,456,16,168,32,8,104,8,104,8,0.00
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-30,16,48,8,8,408,8,144,32,8,56,8,72,8,0.00
7FB47171747D21E9827C2283C59EC1690B058BC6,2010-05-31,16,48,8,8,392,16,176,40,0,64,8,80,8,0.00

trusted
8522EB98C91496E80EC238E732594D1509158E77,2010-05-20,96,328,64,16,1624,72,712,152,8,288,48,536,32,5.79
8522EB98C91496E80EC238E732594D1509158E77,2010-05-21,64,280,56,24,1320,80,696,128,8,288,32,496,24,5.74
8522EB98C91496E80EC238E732594D1509158E77,2010-05-22,64,248,24,8,1872,56,608,160,8,280,24,360,32,5.36
8522EB98C91496E80EC238E732594D1509158E77,2010-05-23,72,272,32,8,1816,64,584,160,8,288,24,376,24,5.45
8522EB98C91496E80EC238E732594D1509158E77,2010-05-25,88,256,56,24,1944,64,648,176,8,288,32,416,40,4.53
8522EB98C91496E80EC238E732594D1509158E77,2010-05-26,64,176,56,24,1576,48,544,176,8,280,24,352,32,2.88
8522EB98C91496E80EC238E732594D1509158E77,2010-05-27,64,152,64,24,1240,32,592,168,8,264,32,304,24,0.81
8522EB98C91496E80EC238E732594D1509158E77,2010-05-28,56,176,64,16,1400,32,680,144,0,320,24,288,24,0.89
8522EB98C91496E80EC238E732594D1509158E77,2010-05-29,40,112,24,8,952,16,360,72,8,168,16,152,8,0.00
8522EB98C91496E80EC238E732594D1509158E77,2010-05-30,56,200,32,8,1496,24,552,128,8,240,8,288,24,0.00
8522EB98C91496E80EC238E732594D1509158E77,2010-05-31,96,320,64,24,2360,64,888,240,8,360,16,464,56,0.00

blutmagie
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-20,8,7368,8,0,128,8,80,16,0,0,8,32,8,0.00
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-21,16,4088,8,0,112,16,88,16,8,0,8,16,8,0.10
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-22,8,4608,16,0,312,16,144,32,0,0,0,32,8,0.18
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-23,8,2632,16,0,184,8,88,8,0,0,8,16,8,0.00
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-24,16,4216,8,0,216,16,104,16,0,0,8,24,8,0.02
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-25,8,4024,16,0,248,16,96,24,0,0,8,32,8,0.01
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-26,16,4096,16,0,224,24,88,16,0,0,8,40,8,0.03
6297B13A687B521A59C6BD79188A2501EC03A065,2010-05-28,8,2912,8,0,168,16,112,16,0,0,8,56,8,0.10

Something happened on May 29, but I have no clue what.

comment:6 Changed 9 years ago by Falo

is there anything I can do?

comment:7 Changed 9 years ago by karsten

Can you check if it's working now? All three directories as stated above are now reporting non-zero shares again:

7FB47171747D21E9827C2283C59EC1690B058BC6,2010-06-01,16,48,16,8,392,16,152,32,8,64,8,88,16,0.07
8522EB98C91496E80EC238E732594D1509158E77,2010-06-01,40,232,56,24,1864,48,632,144,8,304,24,376,40,1.34
6297B13A687B521A59C6BD79188A2501EC03A065,2010-06-01,16,3192,24,0,368,16,128,32,0,0,8,80,8,0.29

No idea if this is related (though somehow blutmagie must have reported those numbers) and what caused the 0.00 shares.

comment:8 Changed 9 years ago by Falo

everything is working now.

comment:9 Changed 9 years ago by karsten

To recap, we have (1) a breaking directory mirror due to gathering statistics and (2) falsely reported statistics here. Whether the two issues are related was just a guess because both appeared at the same time. But now the directory mirror is running fine, whereas the reported statistics are still wrong. Maybe there's no such relation here.

We are working on (2) and have even found what causes the bug (#1564). All discussions of the 0.00% shares should go there.

However, we don't have any starting point for tracking down the bug reported here (1). I'm leaving this task open for now, but we need more information to start working on it.

comment:10 Changed 9 years ago by karsten

Resolution: worksforme
Status: assignedclosed

Looks like the problem is gone. Closing this task. Please re-open if the problem shows up again.

comment:11 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:12 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.