Opened 5 years ago

Closed 5 years ago

#15182 closed defect (duplicate)

Tor Browser fails to start

Reported by: cainy393 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When trying to launch tor browser it almost always does not work for me. I'm running a windows 7 home premium OS, very recently freshly installed and the problem persisted through onto the clean install of win 7.

When I run tor browser, both the tor.exe and firefox.exe processes start up and I can see them running in my task manager processes tab. Despite this, the tor browser window never appears. Attempting to start the browser again results in a "browser is already running" error. Only way to get round this is to manually kill the firefox.exe process and try again. Sometimes after several attempts the browser launches without any apparent changes.

I suspect this may be something to do with file permissions and having read/write access based on various things I've seen whilst googling this problem but I could be making that up completely. On occasion, moving the whole browser bundle to a new directory seems to fix the problem temporarily. Currently I have it in my user folder.

Tor browser version 4.0.4 at current although the problem has been persisting for a few versions.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by cainy393

Forgot to add, tor.exe itself seems to function fine, I can proxy other applications through it without issue. The problem seems to be simply that firefox never loads up the GUI, despite running in the background somewhere.

comment:2 Changed 5 years ago by mcs

Cc: brade mcs added

This may be a duplicate of #10804. If you disable HTTPS Everywhere (not recommended as a permanent solution), does this problem disappear? See ticket:10804#comment:13

Last edited 5 years ago by mcs (previous) (diff)

comment:3 Changed 5 years ago by mcs

Resolution: duplicate
Status: newclosed

Based on ticket:15669#comment:2, I am closing this as a duplicate of #10804. Please reopen this ticket if this is a different issue.

Note: See TracTickets for help on using tickets.