Opened 5 years ago

Closed 5 years ago

#15183 closed defect (duplicate)

TUMBLR - HTTPS Everywhere v 4.0.3 on Firefox Breaks User-Posted Tumblr Pictures

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

User posted pictures disappear, leaving only a hyperlink which will not load the pictures (probably the picture "alt" tag). Disabling HTTPS everywhere instantly loads them all, re-enabling instantly removes them. Does not matter whether logged into Tumblr or not. Observed on current Firefox w/HTTPS Everywhere plugin running on Win 7 and Win 8.1.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by gk

Component: - Select a componentEFF-HTTPS Everywhere

comment:2 Changed 5 years ago by habakuk

Keywords: httpse-ruleset-bug added

comment:3 Changed 5 years ago by habakuk

If I try to open such an image I get this error:

e.g. on http://fuckyouverymuch.dk/post/113163201415/we-still-think-biggie-is-the-illest
this link https://gs1.wac.edgecastcdn.net/8019B6/data.tumblr.com/f6feb4918e2a7cd55cd030dcfec04ace/tumblr_nky5texPfC1qza249o1_500.png

<Error>
   <Code>AccessDenied</Code>
   <Message>Access Denied</Message>
   <RequestId>509E89374C707226</RequestId>
   <HostId>UyPKlobPk+kSTtyKFTGSL9Mr+21Wy01b7OenPuE5VdXgj4pyd8uEzgGSX0lHvdgC</HostId>
</Error>

Or
https://gs1.wac.edgecastcdn.net/8019B6/data.tumblr.com/11621ce56e7a4e96c0949b450ebdd729/tumblr_nkrrbi18wQ1tl5t55o1_1280.png
on http://www.alicegrove.com/post/112839424544/all-right-already-we-all-float-on
original link url: http://www.alicegrove.com/image/112839424544

<Error>
   <Code>AccessDenied</Code>
   <Message>Access Denied</Message>
   <RequestId>02332300D1AA3B33</RequestId>
   <HostId>lovXFaD7ujknkM07LAv6cOMm6ZHuMEI22YDzfB3yZMGgUCudNiOV+RIuSFl/axd4</HostId>
</Error>

comment:4 Changed 5 years ago by cypherpunks

Another test case: superpringle.tumblr.com/post/113325634646/the-new-mario-level-is-weird

Disabling the ruleset for tumblr is sufficient to make it work. The problem started within the past week or so.

comment:5 Changed 5 years ago by bradjshannon

Bug confirmed, reproduced. Doesn't matter if the image is uploaded to Tumblr or provided as URL -- Tumblr fails to serve the image properly when the HTTPS Everywhere rule "Tumblr (partial)" is in effect. Disabling that rule solves the problem, allowing those images to appear.

Even with the rule disabled, Tumblr uses HTTPS, at least in my case (I am logged in).

Contact me if I can help in any way.

comment:6 Changed 5 years ago by gmorehouse

Resolution: duplicate
Status: newclosed

Duplicate of #9642, now biting very badly in the wild.

Note: See TracTickets for help on using tickets.