Opened 4 years ago

Closed 4 years ago

#15201 closed defect (fixed)

Windows: disable "runas" code path in updater

Reported by: mcs Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: firefox-patch, tbb-4.5-alpha, TorBrowserTeam201503
Cc: brade, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Windows, for safety's sake, we should disable the "runas" code path that is used when the user does not have write access to the directory where the browser is installed. Because we require write access to the profile, we don't expect that this change will inconvenience many (if any) users.

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by mcs

Keywords: firefox-patch tbb-4.5-alpha TorBrowserTeam201503 added

comment:2 Changed 4 years ago by mikeperry

Oh crap, I merged brade/bug15201-01 before you set this ticket in needs_review. While looking at other branches, I saw the branch and it seemed ok to me.

Let me know if you discover any issues with it, and we can remove it or fix it when we rebase on top of 31.6.0ESR. Otherwise, feel free to just close this ticket!

comment:3 in reply to:  2 Changed 4 years ago by mcs

Replying to mikeperry:

Oh crap, I merged brade/bug15201-01 before you set this ticket in needs_review. While looking at other branches, I saw the branch and it seemed ok to me.

Let me know if you discover any issues with it, and we can remove it or fix it when we rebase on top of 31.6.0ESR. Otherwise, feel free to just close this ticket!

An aggressive merge, although I do not think the code is harmful. Kathy and I were trying to finish it on Friday but ran out of time, and then Kathy and I were both afk this entire weekend. When we tested a Windows build that includes the patch, we confirmed that the UAC prompt does not appear (good) but no error message was displayed (bad, or at least not what we expected). That is why we did not mark it as ready for review. We will do some more testing early this week and can fix the error handling with a followup patch if necessary. Since it is so difficult for users to shoot themselves in the foot in this way (given the standalone nature of our Tor Browser install), I do not think reporting an error is crucial.

comment:4 Changed 4 years ago by mcs

Resolution: fixed
Status: newclosed

I opened a new ticket to track the "lack of an error message" issue: #15491

Note: See TracTickets for help on using tickets.