Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1521 closed defect (duplicate)

Changing OrPort to 0 doesn't terminate relaying instantly

Reported by: Sebastian Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

helmut on #tor reports that when a node's configuration is updated, existing connections aren't closed instantly even though relaying should be disabled.

Is this intentional? Is there a way to immediately close the connections (other than shutdown of course)?

Child Tickets

Change History (5)

comment:1 Changed 9 years ago by nickm

I believe that it's intentional that setting ORPort to 0 disables new connections, and lets old ones go on for a while to give them a chance to finish. It's not nice to suddenly kill people's circuits.

I'm not aware of a way to immediately close all the connections besides just killing the process.

comment:2 Changed 9 years ago by Sebastian

hm ok, I'm wondering because some connections might be extremely long-lived or high traffic. Maybe setting clientonly should have this effect?

comment:3 Changed 9 years ago by nickm

Resolution: duplicate
Status: newclosed

Looks like a duplicate of bug #525.

comment:4 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:5 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.