Opened 5 years ago

Closed 4 years ago

#15221 closed defect (fixed)

Tor crash : bad syscall attempt (syscall prlimit64)

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: 027-backport
Cc: Actual Points:
Parent ID: Points: small/medium
Reviewer: Sponsor:

Description

SandBox 1
ControlSocket /var/run/tor/control

As soon I attach arm on the control socket , tor dies :

[Time...] [notice] Tor 0.2.7.0-alpha-dev (git-189f357f9790c30e) opening log file.
...
[Time...] [notice] New control connection opened.

============================================================ T= 1426029732
(Sandbox) Caught a bad syscall attempt (syscall prlimit64)
/usr/sbin/tor(+0x15aaec)[0xb762faec]
linux-gate.so.1(__kernel_vsyscall+0x10)[0xb74b3bbc]
linux-gate.so.1(__kernel_vsyscall+0x10)[0xb74b3bbc]
/lib/i386-linux-gnu/i686/cmov/libc.so.6(getrlimit64+0x2b)[0xb70a5bbb]
/usr/sbin/tor(set_max_file_descriptors+0x3a)[0xb7614d6a]
/usr/sbin/tor(+0xf9861)[0xb75ce861]
/usr/sbin/tor(connection_control_process_inbuf+0x260c)[0xb75d654c]
/usr/sbin/tor(+0xdd86d)[0xb75b286d]
/usr/sbin/tor(+0xe8d6f)[0xb75bdd6f]
/usr/sbin/tor(+0x2ac69)[0xb74ffc69]
/usr/lib/i386-linux-gnu/libevent-2.0.so.5(event_base_loop+0x73d)[0xb73df36d]
/usr/sbin/tor(do_main_loop+0x24d)[0xb750183d]
/usr/sbin/tor(tor_main+0x14e5)[0xb75046b5]
/usr/sbin/tor(main+0x35)[0xb74fd955]
/lib/i386-linux-gnu/i686/cmov/libc.so.6(__libc_start_main+0xf3)[0xb6fdea63]
/usr/sbin/tor(+0x289a4)[0xb74fd9a4]

Child Tickets

Change History (15)

comment:1 Changed 5 years ago by arma

Does the same thing happen on Tor 0.2.6.4-rc?

comment:2 Changed 5 years ago by nickm

This works for me on current 0.2.6 and 0.2.7 when I connect with netcat; I wonder what's going on...

comment:3 Changed 5 years ago by nickm

Status: newassigned

comment:4 Changed 5 years ago by nickm

Keywords: 027-triaged-1-out added

Marking triaged-out items from first round of 0.2.7 triage.

comment:5 Changed 5 years ago by nickm

Milestone: Tor: 0.2.7.x-finalTor: 0.2.???

Make all non-needs_review, non-needs_revision, 027-triaged-1-out items belong to 0.2.???

comment:6 Changed 5 years ago by anonym

This also affects Tails and can be reproduced in e.g. Tails 1.3.2 (due to how we limit the normal user from accessing the (full) Tor control port, you'll have to set an administration password before logging in and run it with sudo arm).

comment:7 Changed 5 years ago by anonym

Keywords: AffectsTails added

comment:8 Changed 4 years ago by nickm

Milestone: Tor: 0.2.???Tor: 0.2.8.x-final

comment:9 Changed 4 years ago by dgoulet

Keywords: Sandbox Bad syscall 027-triaged-1-out AffectsTails removed
Points: small/medium
Version: Tor: unspecified

comment:10 Changed 4 years ago by nickm

Keywords: must-fix-before-028-rc added

Marking these as must-fix-before-028-rc.

Actually, some of them may not need to get 'fixed' before the rc, but I believe that they should either get fixed, or we should have a good explanation of why they don't need to get fixed.

comment:11 Changed 4 years ago by nickm

Keywords: 027-backport added
Severity: Normal
Status: assignedneeds_review

Possible fix in branch bug15221_027.

comment:12 Changed 4 years ago by dgoulet

lgtm.

comment:13 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-finalTor: 0.2.7.x-final

Merged to 0.2.8, marking for 0.2.7 backport.

comment:14 Changed 4 years ago by nickm

Keywords: must-fix-before-028-rc removed

comment:15 Changed 4 years ago by andrea

Resolution: fixed
Status: needs_reviewclosed

Crash bug should clearly be backported; merged into maint-0.2.7 and closing this ticket.

Note: See TracTickets for help on using tickets.