Opened 4 years ago

Closed 3 years ago

#15222 closed defect (duplicate)

Only works when URL bar is showing

Reported by: DNied Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If the address bar is hidden in Firefox, the Tor button (placed on the status bar) does not work. Found on all recent versions of Firefox on Linux.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by gk

Component: TorbuttonTor Browser
Keywords: tbb-torbutton added
Status: newneeds_information

Could you give me exact steps to reproduce your problem (assuming an up-to-date Tor Browser)?

comment:2 in reply to:  1 Changed 4 years ago by DNied

Replying to gk:

Could you give me exact steps to reproduce your problem (assuming an up-to-date Tor Browser)?

Yes. Sorry for not mentioning that you'll need the Vimperator (or Pentadactyl) extension to do this, but it used to be that you could hide the "Navigation Toolbar" from the View->Toolbars menu. Now the geniuses at Mozilla have removed that option.

Anyway. Customize toolbars to move the Torbutton on a different toolbar, for example Vimperator's status bar on the bottom. Now hide the navigation bar by entering

:set gui=nonavigation

in Vimperator's status line (hit Esc first if not in command mode). The Navigation Bar is hidden and the Torbutton won't work. Now try

:set gui+=navigation

the Navigation Bar is shown and the Torbutton will work again.

There are probably other extensions or undocumented ways to hide the Navigation Toolbar. I'm almost sure the Torbutton won't work even when the bar is hidden via other means: In other words, I really don't think this is a Vimperator issue, rather a Torbutton issue.

comment:3 Changed 3 years ago by bugzilla

Resolution: duplicate
Severity: Normal
Status: needs_informationclosed

Closed as a duplicate of #12514.

Note: See TracTickets for help on using tickets.