Opened 6 years ago

Closed 3 years ago

#15243 closed enhancement (duplicate)

Allow multiple Tor instances to share directory info, guards, and who knows what else?

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: hard tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Frequently people want applications to run in a one-tor-per-app model. Sometimes, people want systems to run in a one-tor-per-user model. The main problem here is that some information (like choice of guards) should be consistent across all Tors, and some effort (like fetching directory information) is needlessly duplicated across all Tors.

We should look for designs that fix this.

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by nickm

Severity: Normal

Closing as duplicate of #13932.

comment:2 Changed 3 years ago by nickm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.