Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15296 closed defect (fixed)

Remove extra newline at the end of an HS descriptor

Reported by: dgoulet Owned by: dgoulet
Priority: Very Low Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7
Severity: Keywords: tor-hs, 027-triaged-1-in
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor: SponsorR

Description

In rend_encode_v2_descriptors, an extra newline is added at the end of the descriptor. However, rend-spec.txt doesn't specify this extra newline.

atagar mentionned on IRC that it would be surprising if that is the intended behaviour since other type of descriptors don't have it:

< atagar> It's the only descriptor type with it, so I'd be surprised if it was intended. ;)

Thus this should be fixed in the tor code and not in the spec.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by dgoulet

Status: newneeds_review

Fix in branch bug15296_027_01.

This has been tested on a chutney network, it works perfectly. Also, current HSDir and Client are fined because the HS descriptor parsing doesn't expect a newline thus currently ignores it. I've also tested it in a chutney network with an HS uploading its descriptor without that newline to an unpatched HSDir. Everything works fine.

comment:2 Changed 4 years ago by nickm

Merged. Also added a changes file.

comment:3 Changed 4 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

comment:4 Changed 4 years ago by isabela

Keywords: SponsorR 027-triaged-1-in added
Points: small
Priority: normaltrivial
Version: Tor: 0.2.7

comment:5 Changed 4 years ago by dgoulet

Keywords: SponsorR removed
Sponsor: SponsorR
Note: See TracTickets for help on using tickets.