Opened 3 years ago

Closed 9 months ago

#15353 closed defect (fixed)

Some chutney tests fail when localhost is the only available IP

Reported by: teor Owned by: nickm
Priority: Low Milestone:
Component: Core Tor/Chutney Version:
Severity: Normal Keywords: tor-chutney-usability
Cc: nickm, dgoulet Actual Points:
Parent ID: #21903 Points: 2
Reviewer: Sponsor: SponsorS-can

Description

When I turn off the Wifi / Internet connection on my Mac (OS X 10.10.2), the chutney Exit tests fail with 'no exit to that port', but the hidden service tests are fine.

This is probably a misconfiguration around the localhost exit ports (all ports should be allowed, or, at the very least, the ports chutney uses should be allowed).

I'll see if I can find time to track this down and fix it, but it's low priority, as most people run chutney on a computer with an IP address apart from localhost.

Child Tickets

Change History (15)

comment:1 Changed 3 years ago by teor

I think this has to do with the default exclusion of local and private addresses from exit policies.

It should be able to be fixed by adding:

accept[6] private:*

to the appropriate location in the exit-v[4|6].i templates.

I'll work on a patch for this.

comment:2 Changed 3 years ago by teor

Apparently not. There must be something more complicated happening in the code and/or config.
That is irritating, it looks like it's going to take more time than I have right now.

comment:3 Changed 3 years ago by teor

I think this is due to #16971 - Testing tor networks use external DNS for dns checks

comment:4 Changed 3 years ago by teor

Or perhaps #12377 - get_interface_address6() behaviour iff all interface addresses are internal

comment:5 Changed 3 years ago by teor

See my branch sent_no_bytes in https://github.com/teor2345/chutney.git

It doesn't solve the problem, but it does exit when it happens, rather than hanging.
I am now wondering whether the issue is with Tor or chutney.

comment:6 Changed 3 years ago by teor

Status: newneeds_review

comment:7 Changed 3 years ago by teor

Keywords: 027-backport added

comment:8 Changed 3 years ago by teor

Keywords: 027-backport removed

Updated the branch sent_no_bytes to sleep before retries.

I'm not sure what the backport tag was doing in a chutney task.

comment:9 Changed 3 years ago by nickm

Resolution: fixed
Severity: Normal
Status: needs_reviewclosed

Merged it!

comment:10 Changed 3 years ago by teor

Resolution: fixed
Status: closedreopened

That was a diagnostic branch, not a fix branch :-)

It's great to have it merged, as chutney won't hang, but it would be even better to have the issue fixed.

comment:11 Changed 2 years ago by nickm

Keywords: tor-chutney-usability added

comment:12 Changed 2 years ago by nickm

Points: 2

comment:13 Changed 2 years ago by nickm

Sponsor: SponsorS-can

comment:14 Changed 14 months ago by teor

Parent ID: #21903

I think #21903 will fix this.

comment:15 Changed 9 months ago by teor

Resolution: fixed
Status: reopenedclosed

Fixed in #21903.

Note: See TracTickets for help on using tickets.