Opened 4 years ago

Closed 4 years ago

#15354 closed defect (duplicate)

tor dies on reload (after chaning unusual config settings)

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.4-rc
Severity: Keywords:
Cc: nusenu@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

reproducer:

start tor with the following command:

tor -f torrc --runasdaemon 0

torrc contains:

User debian-tor
DataDirectory /var/lib/tor
Log debug file /var/log/tor/log
DisableDebuggerAttachment 0
RunAsDaemon 1

modify the torrc file:

3,5c3
< Log debug file /var/log/tor/log
< DisableDebuggerAttachment 0
< RunAsDaemon 1
---
> Log notice file /var/log/tor/log

Send the tor process the HUP signal for reload.

tor will die:

Tor 0.2.6.4-rc (git-b7090ba4fb85d8ac) died: Caught signal 11
/usr/bin/tor(+0x11b4f7)[0x7f43001fe4f7]
/lib/x86_64-linux-gnu/libpthread.so.0(pthread_mutex_lock+0x4)[0x7f42fecd8274]
/lib/x86_64-linux-gnu/libpthread.so.0(pthread_mutex_lock+0x4)[0x7f42fecd8274]
/usr/bin/tor(tor_mutex_acquire+0x1e)[0x7f43002193de]
/usr/bin/tor(threadpool_queue_update+0x42)[0x7f4300218a72]
/usr/bin/tor(cpuworkers_rotate_keyinfo+0x38)[0x7f43001ce498]
/usr/bin/tor(set_options+0xf79)[0x7f43001a9499]
/usr/bin/tor(options_init_from_string+0x31a)[0x7f43001aabfa]
/usr/bin/tor(options_init_from_torrc+0x1d6)[0x7f43001aaf36]
/usr/bin/tor(process_signal+0x709)[0x7f430011bff9]
/usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0xe35)[0x7f42ff76ca15]
/usr/bin/tor(do_main_loop+0x194)[0x7f430011abd4]
/usr/bin/tor(tor_main+0x16b5)[0x7f430011d9e5]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f42fe742b45]

(this is *not* related to my systemd unit file debugging - I made sure this is reproducible without using systemd)

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by tyseom

Cc: nusenu@… added

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.6.x-final
Resolution: duplicate
Status: newclosed

Thanks! This appears to be a duplicate of #15245 .

Note: See TracTickets for help on using tickets.