Opened 5 years ago

Closed 5 years ago

#15370 closed defect (not a bug)

Multiple launch of Tor Browser pointed to the same Firefox profile folder

Reported by: trlaunch01 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In version 3.6.3 i was able to launch Tor Browser in following way:
{TOR_BROWSER_FOLDER}\Browser\firefox.exe -profile .\Data\Browser\profile.default\
This command line is same as "Start Tor Browser.exe" is using, but without parameter "-no-remote". In such way i was able execute Tor Browser multiple times and each time a new browser window was opened, which was very convenient for me.

But in versions 4.x, especially in 4.0.4 the things changed. Now second and further executions of command line
{TOR_BROWSER_FOLDER}\Browser\firefox.exe -profile .\Data\Browser\profile.default\
result in message box with error "Firefox is already running but not responding..."

So, my question is - how can i in 4.x versions launch Tor Browser multiple times and point it to the same profile folder, so new browser window will be produced for each launch?

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by mcs

Resolution: not a bug
Status: newclosed

In Tor Browser 4 and newer, -no-remote is the default behavior. You can enable remoting by including a -allow-remote command line flag. This change was made as part of #11641.

Also, you can omit the -profile option because Tor Browser 4.x knows where to find the default profile.

Please reopen this ticket if -allow-remote does not resolve this issue for you.

Note: See TracTickets for help on using tickets.