Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#1538 closed task (implemented)

Pre-configured bridge relay for Windows

Reported by: phobos Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Develop a bundle that on start up turns the user into a published bridge relay. Do so with existing technology.

Child Tickets

Change History (13)

comment:1 Changed 9 years ago by phobos

Status: newaccepted

comment:2 Changed 9 years ago by phobos

Type: defecttask

comment:3 Changed 9 years ago by phobos

https://trac.vidalia-project.net/changeset/4313 is all that was needed to make this work.

comment:4 Changed 9 years ago by phobos

Summary: User Story: Pre-configured bridge relay for WindowsPre-configured bridge relay for Windows

comment:5 Changed 9 years ago by phobos

Resolution: invalid
Status: acceptedclosed

The proper way to do this is by implementing upnp/nat-pmp into tor itself. This process is underway.

comment:6 Changed 9 years ago by arma

Resolution: invalid
Status: closedreopened

comment:7 Changed 9 years ago by arma

Putting upnp in Tor is a good start, but not the same as having a Windows bundle with the bridge box preclicked.

That said, this was designed as a quick hack to let Sina et al tell people to just run that version of Tor, and you'll be helping out more. But we need to wait until #98 is resolved, or we'll probably be hurting more than helping.

Leaving trac entry open since we may still want to do this quick hack later on -- I expect #98 will be resolved much sooner than we'll finish a "Tor opts to become a bridge" deployment.

comment:8 Changed 9 years ago by phobos

Owner: changed from phobos to erinn
Status: reopenedassigned

comment:9 Changed 9 years ago by phobos

Priority: normalmajor

Bumping up the priority on this because we now have more people interested in this bundle living and being deployed. It will also deliver some data as to how many new bridges are created versus how many downloads this bundle receives.

comment:10 Changed 8 years ago by rransom

These have been built and blogged, but need to be added to the download page.

comment:11 Changed 8 years ago by phobos

Is this considered complete? 

comment:12 Changed 8 years ago by arma

Resolution: implemented
Status: assignedclosed

I see them on the download page now. I'm going to call this one closed.

comment:13 Changed 8 years ago by karsten

Milestone: Experimental Bridge Bundles

Removing the milestone. This isn't how milestones are supposed to work. "Experimental Bridge Bundles" is a task or maybe a project, but not a milestone. The next time we should use a parent ticket instead. I'm not creating one now, because nobody cares anymore.

Note: See TracTickets for help on using tickets.