Opened 4 years ago

Closed 4 years ago

#15452 closed defect (implemented)

Remove obsolete version checks

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We have some code sitting around for working around very old versions that don't run on the network any more. Let's remove it!

See branch remove_old_version_checks in my public repository.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by nickm

Status: newneeds_review

comment:2 Changed 4 years ago by yawning

Both "Stop checking for torrc state files generated by very old Tor versions" and "Remove version checks for microdescriptor support" LGTM, not sure if you're going to go on a hunt for more ancient workarounds.

comment:3 Changed 4 years ago by nickm

Resolution: implemented
Status: needs_reviewclosed

Merged! That's all I found.

Note: See TracTickets for help on using tickets.