Opened 5 years ago

Closed 3 years ago

#15453 closed defect (duplicate)

Globe's bandwidth graphs over 3 days/1 week do not update for relays running Tor >= 2.5.11

Reported by: gok Owned by: phw
Priority: Medium Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords: graphing, ui
Cc: ghostofkendo@…, jniles Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Globe fails to correctly update the bandwidth graphs for the 3 days and 1 week periods when the observed relay runs Tor >= 2.5.11.

The 3 days/1 week bandwidth graphs show either "No data available :(" or partial lines if the period encompasses data points generated before the upgrade to Tor 2.5.11.
The graphs over 1 month, 3 months, and 1 year periods still work fine, i.e they include data points generated after the upgrade to Tor 2.5.11.

I guess it is caused by the increased period (from 15 minutes to 4 hours) over which bandwidth observations are aggregated since Tor 2.5.11 (see https://trac.torproject.org/projects/tor/ticket/13988).

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by gok

Cc: ghostofkendo@… added

comment:2 Changed 4 years ago by isis

Cc: jniles added
Keywords: graphing ui added; stats removed

I marked #16184 as a duplicate of this ticket. Adding its reporter to the CC list on this one.

comment:3 Changed 4 years ago by cypherpunks

globe/atlas are innocent and report correctly "No data available :(".

Historic bandwidth data are still missing for time period "3_days" and "1_week"

Example:
https://onionoo.torproject.org/bandwidth?fingerprint=9695DFC35FFEB861329B9F1AB04C46397020CE31

Who compute these historical bandwidth data? Authdir servers scripts?

greets cypherpunks

comment:4 Changed 3 years ago by karsten

Component: Metrics/GlobeMetrics/Atlas
Owner: changed from isis to phw
Severity: Normal

We're shutting down Globe, but Atlas has the same issue, so switching component.

So, it's correct that this issue is caused by relays reporting bandwidth data for 4 hours rather than 15 minutes as before. That's also why Onionoo stopped giving out data covering 3 days and 1 week, because those would have been on a granularity of 15 minutes and 1 hour, respectively, and data on that granularity level is simply not available anymore. The first data series with 4 hour intervals is 1 month and that is still given out by Onionoo.

What Atlas should do is take the 1 month data series as input and graph only the last 3 days or 1 week if it wants to keep its graphs. They will have a lower data resolution, but that's exactly because the data resolution provided by relays is now lower. Or it could remove those two graphs and start with 1 month.

comment:5 Changed 3 years ago by karsten

Resolution: duplicate
Status: newclosed

Closing as duplicate of #19553.

Note: See TracTickets for help on using tickets.