Opened 4 years ago

Closed 4 years ago

#15480 closed defect (fixed)

Tor Check's TorBulkExitList.py script returns duplicated addresses

Reported by: isis Owned by: arlolra
Priority: Medium Milestone:
Component: Applications/Tor Check Version:
Severity: Keywords: bulkexitlist, tor-check
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For example, part of the results from https://check.torproject.org/cgi-bin/TorBulkExitList.py?ip=38.229.72.19&port=443 just now:

37.130.227.133
37.130.227.133
37.131.185.47
37.139.3.171
37.143.9.74
37.147.45.175
37.157.192.208
37.157.194.210
37.157.195.178
37.157.195.83
37.187.107.210
37.187.114.36
37.187.129.166
37.187.129.166
37.187.2.229
37.187.21.180
37.187.239.191
37.187.244.40
37.187.246.221
37.187.38.147
37.187.39.210
37.187.51.210

which has multiple duplicates.

I assume the script has a list.sort() somewhere in there. All that is needed to get rid of the duplicates is set(list.sort().

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by arlolra

Resolution: fixed
Status: newclosed

The .py in that url is bit misleading; check is written in go. A friendlier url is https://check.torproject.org/torbulkexitlist (but I just had to fix that so maybe you already knew about it).

Duplication is fixed in f506e693. The commit message has some info about what's going on but the problem is more apparent in https://check.torproject.org/api/bulk?ip=38.229.72.19&port=443

Anyways, thanks for the pointing this out.

Note: See TracTickets for help on using tickets.