Opened 4 years ago

Closed 4 years ago

#15496 closed defect (fixed)

HTTPS everywhere breaks okcupid.com

Reported by: brunoqc Owned by:
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I can't login on okcupid.com unless I disable the "OkCupid.com (partial)" rule.

If not, I get an infinite redirection error.

ERR_TOO_MANY_REDIRECTS with https://www.okcupid.com/login?dest=%2fhome

It seems the problem is only with the login and it seems I can reactivate the rule once logged.

HTTPS Everywhere version 2015.3.23
Chrome 41.0.2272.101 m (64-bit)

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by brunoqc

Note that even if I remove the rule, I need to delete the cookie to access the site again. If not I only can see the ERR_TOO_MANY_REDIRECTS page.

comment:2 Changed 4 years ago by jsha

Resolution: fixed
Status: newclosed

This is fixed in 2015.3.31. Thanks!

Note: See TracTickets for help on using tickets.