Opened 4 years ago

Closed 19 months ago

#15508 closed defect (fixed)

Make uptime sorting numeric and take the actual unit into account

Reported by: cypherpunks Owned by: irl
Priority: High Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords: metrics-2017
Cc: nusenu@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by irl)

Atlas bandwidth sorting is basically broken because it does not use numeric sorting.

example:
https://atlas.torproject.org/#search/contact:torservers

shows:

63.62 KB/s
512 KB/s
31.69 MB/s

Update: Bandwidth and IP address sorting are now fixed, but uptime sorting still needs addressing.

Child Tickets

Change History (14)

comment:1 Changed 4 years ago by tyseom

Cc: nusenu@… added

comment:2 Changed 2 years ago by irl

Priority: MediumHigh
Severity: Normal

comment:3 Changed 2 years ago by teor

As I noted in #22290, this also affects uptime and (to a lesser extent) IP address.

comment:4 Changed 23 months ago by arma

#23137 was a duplicate of this ticket.

comment:6 Changed 22 months ago by irl

Description: modified (diff)
Summary: bandwidth sorting should be numeric and take the actual unit into accountuptime sorting should be numeric and take the actual unit into account

The patch from comment:5 has been merged and deployed. Thanks. (:

comment:7 Changed 21 months ago by karsten

Summary: uptime sorting should be numeric and take the actual unit into accountMake uptime sorting numeric and take the actual unit into account

Tweak summary bit.

By the way, the last comment sounds as if the work is already done. Can this ticket be closed?

comment:8 Changed 21 months ago by teor

No

Update: Bandwidth and IP address sorting are now fixed, but uptime sorting

still needs addressing.

comment:9 Changed 21 months ago by karsten

Keywords: metrics-2018 added

comment:10 Changed 21 months ago by karsten

Keywords: metrics-2017 added; metrics-2018 removed

comment:11 Changed 21 months ago by karsten

Owner: changed from phw to metrics-team
Status: newassigned

comment:12 Changed 20 months ago by irl

Owner: changed from metrics-team to irl

Moving this into my queue.

comment:13 Changed 20 months ago by irl

Status: assignedaccepted

comment:14 Changed 19 months ago by irl

Resolution: fixed
Status: acceptedclosed

Fixed in 45fbd44.

Note: See TracTickets for help on using tickets.