Opened 4 years ago

Closed 4 years ago

#15534 closed defect (duplicate)

Regression test fails in tor dev head

Reported by: yancm Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

One regression test failed after source tree update 2015.03.31/2015.04.01

Tor v0.2.7.0-alpha-dev (git-1ac3cb4823048bc3) running on NetBSD with Libevent 2.1.5-beta, OpenSSL 1.0.1k and Zlib 1.2.3

Failed test:
address/udp_socket_trick_blackbox: [forking]

FAIL src/test/test_address.c:595: assert((retval == -1 && retval_reference == -1)
(tor_addr_compare(&addr4,&addr4_to_check,CMP_EXACT) == 0))

[udp_socket_trick_blackbox FAILED]

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by yawning

Status: newneeds_information

This might be #12377, but I'd need to see the ifconfig and routing table of the box that fails to be sure. (Redact public IPs as appropriate).

comment:2 Changed 4 years ago by yancm

I also just updated to latest git/dev and the teststill fails the same.

As background I have been running development tor for many years on this box. This is new behavior...

Routing tables

Internet:
Destination Gateway Flags
default 10.1.10.1 UG
10.1.10.0/24 link#1 U
10.1.10.1 00:50:f1:80:00:00 UHL
10.1.10.255 link#1 UHL
loopback 127.0.0.1 UGR
localhost 127.0.0.1 UH
192.168.1.0/24 link#2 U
192.168.1.1 00:1b:21:94:ff:8d UHL
192.168.1.2 d0:50:99:25:19:bb UHL
192.168.1.4 00:00:5a:9e:ff:92 UHL
192.168.1.58 link#2 UHL
192.168.1.69 18:e7:f4:17:41:ba UHL
192.168.1.71 00:11:d9:0b:06:3d UHL
192.168.1.75 70:56:81:04:f8:f6 UHL
192.168.1.80 a0:a8:cd:5f:1b:1c UHL
192.168.1.81 9c:ad:ef:10:56:34 UHL
192.168.1.96 ac:cf:5c:ac:77:60 UHL
192.168.1.100 e8:06:88:94:cf:5f UHL
192.168.1.255 link#2 UHL

ifconfig:
wm0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500

capabilities=2bf80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx,TCP6CSUM_Tx,UDP6CSUM_Tx>
enabled=3f80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx>
address: 00:1b:21:95:00:1a
media: Ethernet autoselect (1000baseT full-duplex,flowcontrol,rxpause,txpause)
status: active
inet 10.1.10.10 netmask 0xffffff00 broadcast 10.1.10.255
inet6 fe80::21b:21ff:fe95:1a%wm0 prefixlen 64 scopeid 0x1

wm1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500

capabilities=2bf80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx,TCP6CSUM_Tx,UDP6CSUM_Tx>
enabled=3f80<TSO4,IP4CSUM_Rx,IP4CSUM_Tx,TCP4CSUM_Rx,TCP4CSUM_Tx,UDP4CSUM_Rx,UDP4CSUM_Tx>
address: 00:1b:21:94:ff:8d
media: Ethernet autoselect (1000baseT full-duplex,flowcontrol,rxpause,txpause)
status: active
inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
inet6 fe80::21b:21ff:fe94:ff8d%wm1 prefixlen 64 scopeid 0x2

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 33192

inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3

comment:3 Changed 4 years ago by yancm

Status: needs_informationnew

comment:4 Changed 4 years ago by yawning

Resolution: duplicate
Status: newclosed

Yeah, this is a duplicate of #12377, get_interface_address6() doesn't do the right thing when there's multiple (non-loopback/multicast) addresses of the same family so the test fails since it's written under the assumption that the code it's calling is correct.

The regression test was added recently to try to extend coverage to certain routines.

Note: See TracTickets for help on using tickets.