Opened 5 years ago

Closed 4 years ago

#15543 closed defect (duplicate)

Undocumented + and / for config options

Reported by: atagar Owned by:
Priority: Low Milestone: Tor: 0.2.8.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: doc easy
Cc: Actual Points:
Parent ID: Points: small
Reviewer: Sponsor:

Description

From #14742, we have special behaviour when a config option when a config option is passed on the commandline with a '+' or '/'...

https://gitweb.torproject.org/stem.git/tree/test/integ/process.py#n199

This looks to presently be undocumented. Obvious guess is 'adds/removed from existing config rather than replacing' but I'm getting some unexpected behavior when I pass '/PublishServerDescriptor'. Probably only works properly for LineList arguments.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by arma

It's not undocumented! Search the man page for the word 'plus' or 'slash'.

But you're totally not the first person to search the man page for \+, and assume it's not documented when you find nothing, so please don't close with not-a-bug quite yet. :)

comment:2 Changed 4 years ago by nickm

Milestone: Tor: 0.2.8.x-final

comment:3 Changed 4 years ago by nickm

Keywords: doc easy added
Points: small

comment:4 Changed 4 years ago by nickm

Resolution: duplicate
Severity: Normal
Status: newclosed

I claim this is already done by b370052ae4182 , and is a duplicate of #13158. Thanks again to joanq for the patch.

Note: See TracTickets for help on using tickets.