Opened 4 years ago

Closed 3 years ago

#15552 closed defect (not a bug)

very large document warning

Reported by: iwakeh Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I just noticed that my mirror logs the "very large file warning" again.
The file in question is out/bandwidth/4610BD605525355E015AB702717DBAAF15290261
It contains many literal 'null' strings (the file has 2.3M):

{"fingerprint":"4610BD605525355E015AB702717DBAAF15290261","write_history":{"3_days":{"first":"2015-03-30 00:22:30","last":"2020-05-11 09:07:30","interval":900,"factor":10.45945945945946,"c\
ount":179460,"values":[0,1,10,16,1,1,0,0,11,32,0,2,0,1,0,0,13,26,9,1,0,0,0,18,2,15,3,0,0,14,20,7,0,1,0,19,3,13,1,15,1,1,0,0,16,1,0,11,0,15,2,20,0,1,3,24,16,5,14,2,0,0,0,12,4,0,21,7,0,0,0,0,0,0,33,3,1,12,19,16,65,28,11,4,7,11,9,67,3,6,5,6,3,9,3,4,67,19,13,7,46,3,5,12,8,8,4,20,11,9,6,10,3,66,8,4,17,6,3,115,4,6,5,4,13,5,9,15,5,74,56,15,5,20,4,12,135,4,4,16,19,72,9,10,19,15,14,7,20,5,9,7,7,72,83,44,16,18,19,6,69,11,14,69,10,17,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,95,4,6,7,8,6,4,14,9,6,4,12,9,4,8,4,3,11,71,69,42,8,15,8,4,108,7,3,76,10,13,6,72,15,10,22,21,6,5,75,5,12,78,9,9,20,179,21,70,5,5,16,12,86,70,27,16,16,11,13,72,15,8,68,5,8,25,13,5,6,11,144,10,82,69,10,8,13,87,454,999,478,15,13,17,460,28,125,110,77,77,7,11,5,null,null,null,null, ...
... ,null,0,0,0]}}}

Did this show up before?

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by karsten

The purpose of this warning was to debug an encoding bug where documents grew bigger and bigger until the hourly cronjob ran out of memory. This specific instance of the warning may be unrelated to that, and maybe we should raise the threshold for this warning higher. Needs investigation.

comment:2 Changed 3 years ago by iwakeh

Resolution: not a bug
Severity: Normal
Status: newclosed

It seems this was a single incident.
Please re-open, if necessary.
Closing.

Note: See TracTickets for help on using tickets.