Opened 5 years ago

Last modified 6 weeks ago

#15569 new defect

Web Notification API icons get no first party on Windows systems

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-linkability, tbb-parity
Cc: gk, brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

See this demo:
https://arthuredelstein.github.io/tordemos/web-notification-demo.html

This seems like a fairly minor issue given that users have to give their permission to show notifications.

Child Tickets

Change History (14)

comment:1 Changed 5 years ago by gk

Cc: gk added

comment:2 Changed 4 years ago by mcs

Cc: brade mcs added
Severity: Normal

comment:3 Changed 3 years ago by bugzilla

Good ticket to add to Mozilla's first-party isolation tickets.

Torbutton INFO: tor SOCKS: https://www.torproject.org/images/onion.jpg via --NoFirstPartyHost-chrome-alert.xul--:0
Torbutton INFO: tor SOCKS: http://ocsp.digicert.com/ via --nofirstpartyhost-chrome-alert.xul--:0

comment:4 Changed 3 years ago by cypherpunks

Parent ID: #21762

comment:5 Changed 3 years ago by gk

Parent ID: #21762

comment:6 Changed 3 years ago by gk

Keywords: ff52-esr-will-have added
Resolution: fixed
Status: newclosed

Works in 7.0a4.

comment:7 Changed 3 years ago by cypherpunks

Keywords: ff52-esr added; ff52-esr-will-have removed
Resolution: fixed
Status: closedreopened

Really?

[05-23 13:29:33] Torbutton INFO: tor SOCKS: https://www.torproject.org/images/onion.jpg via                        --unknown--:2062adaa3c974055406e23c9975e9c56

comment:8 in reply to:  7 Changed 3 years ago by gk

Keywords: ff52-esr removed
Status: reopenedneeds_information

Replying to cypherpunks:

Really?

[05-23 13:29:33] Torbutton INFO: tor SOCKS: https://www.torproject.org/images/onion.jpg via                        --unknown--:2062adaa3c974055406e23c9975e9c56

On what system does this happen?

comment:9 Changed 3 years ago by cypherpunks

Windows

comment:10 Changed 6 weeks ago by gk

Resolution: worksforme
Status: needs_informationclosed

This works now. I suspect this got fixed by our backported patches for #21569 but have not verified that.

Last edited 6 weeks ago by gk (previous) (diff)

comment:11 Changed 6 weeks ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Nah.

granted web-notification-demo.html:12:15
[12-15 02:56:28] Torbutton INFO: tor SOCKS: https://www.torproject.org/images/onion.jpg via
                       --unknown--:b6591b4fbd21f7e18e54eaca004ba721
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 NEW 0 www.torproject.org:443 SOURCE_ADDR=127.0.0.1:58745 PURPOSE=USER
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 SENTCONNECT 535 www.torproject.org:443
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 REMAP 535 116.202.120.165:443 SOURCE=EXIT
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 SUCCEEDED 535 116.202.120.165:443
TypeError: this.service is undefined
PushComponents.jsm:236:5
[12-15 02:56:34] Torbutton INFO: controlPort >> 650 STREAM 3908 CLOSED 535 116.202.120.165:443 REASON=END REMOTE_REASON=DONE
TypeError: this.service is undefined
PushComponents.jsm:240:5
[12-15 02:58:39] Torbutton INFO: controlPort >> 650 STREAM 3900 CLOSED 536 185.199.110.153:443 REASON=DONE

comment:12 in reply to:  11 Changed 6 weeks ago by gk

Status: reopenedneeds_information

Replying to cypherpunks:

Nah.

granted web-notification-demo.html:12:15
[12-15 02:56:28] Torbutton INFO: tor SOCKS: https://www.torproject.org/images/onion.jpg via
                       --unknown--:b6591b4fbd21f7e18e54eaca004ba721
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 NEW 0 www.torproject.org:443 SOURCE_ADDR=127.0.0.1:58745 PURPOSE=USER
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 SENTCONNECT 535 www.torproject.org:443
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 REMAP 535 116.202.120.165:443 SOURCE=EXIT
[12-15 02:56:28] Torbutton INFO: controlPort >> 650 STREAM 3908 SUCCEEDED 535 116.202.120.165:443
TypeError: this.service is undefined
PushComponents.jsm:236:5
[12-15 02:56:34] Torbutton INFO: controlPort >> 650 STREAM 3908 CLOSED 535 116.202.120.165:443 REASON=END REMOTE_REASON=DONE
TypeError: this.service is undefined
PushComponents.jsm:240:5
[12-15 02:58:39] Torbutton INFO: controlPort >> 650 STREAM 3900 CLOSED 536 185.199.110.153:443 REASON=DONE

Could you please add steps to reproduce your findings? Which operating system are you using? Which Tor Browser version?

I can't reproduce the bug anymore on a Linux box with 9.5a3.

comment:13 Changed 6 weeks ago by cypherpunks

I can't reproduce the bug anymore on a Linux box with 9.5a3.

Because comment:9, heh.

comment:14 Changed 6 weeks ago by gk

Keywords: tbb-parity added
Status: needs_informationnew
Summary: Web Notification API icons get no first partyWeb Notification API icons get no first party on Windows systems

Okay, I did not check mobile but on Linux and macOS this works fine, just Windows is affected. Weird.

Note: See TracTickets for help on using tickets.