Opened 3 years ago

Closed 3 years ago

#15586 closed defect (wontfix)

Tor Browser cannot be launched by different users on OS X.

Reported by: Sherief Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: ux, tbb-usability, osx
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser cannot be launched by any user other than the one who installed it on OS X.

How to reproduce:

  • Install Tor Browser on an OS X admin account, launch it.
  • Enable the guest account, attempt to launched it. (fails.)
  • Create a normal account (or even another admin), try to launch Tor Browser from it. (fails.)
  • Change the TorBrowser.app permission to "everyone: read&write" using "Get Info". All users will still fail to launch Tor Browser running on the main admin user or not.

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by Sherief

Cc: mcs brade added

comment:2 Changed 3 years ago by Sherief

After talking with Sebastian I realized that the TorBrowser.app doesn't really act like any other OS X app with multiuser support. Maybe we have have a different error message than "Profile error" and change it to "Sorry, you need a different TorBrowser.app to use for this user".

Note: Tested using TB-4.5a5.

comment:3 Changed 3 years ago by mrphs

Keywords: ux tbb-usability added

comment:4 Changed 3 years ago by mrphs

This confusion begins where we ask people to drag the Tor Browser into Application folder.
Public assumption is that everything in Application folder (which also appears on Launchpad), is available and accessible to all users.

comment:5 Changed 3 years ago by mrphs

Keywords: osx added

comment:6 Changed 3 years ago by mcs

Kathy Brade and I experimented a little with this, but even after we reset permissions to allow multiple users to write to the entire TorBrowser.app directory, the bundled tor is still unhappy. It seems like tor tries hard to not allow people to shoot themselves in the foot -- it prevents sharing of the TorBrowser.app/TorBrowser/Data/Tor directory.

The error message that is displayed if you do not try to adjust file permissions implies that doing so may allow the browser to run, which is true if you make the correct changes... but most people will not know what to do and there does not seem to be a set of permissions that allows for multiple users to share one app bundle.

How common is it for people to have multiple users on Mac OS? In my experience, it is rare. But for those computers where there is more than one user, dragging to /Applications is not a good recommendation. On the other hand, at least on the Mac OS 10.8.5 computer I am testing on at the moment, items places in ~/Applications do not show up in Launchpad.

comment:7 in reply to:  6 Changed 3 years ago by Sherief

Replying to mcs:

Kathy Brade and I experimented a little with this, but even after we reset permissions to allow multiple users to write to the entire TorBrowser.app directory, the bundled tor is still unhappy. It seems like tor tries hard to not allow people to shoot themselves in the foot -- it prevents sharing of the TorBrowser.app/TorBrowser/Data/Tor directory.

The error message that is displayed if you do not try to adjust file permissions implies that doing so may allow the browser to run, which is true if you make the correct changes... but most people will not know what to do and there does not seem to be a set of permissions that allows for multiple users to share one app bundle.

How common is it for people to have multiple users on Mac OS? In my experience, it is rare.

Correct, it's rare and if I were in your place I would not spend time on solving this problem, after all only one user was the reason for this ticket.

In the future, we can say that TorBrowser.app is not really a multiuser application and it needs to be extracted somewhere other than /Applications for it to work for more than one user.

comment:8 Changed 3 years ago by mcs

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.