Opened 5 years ago

Closed 5 years ago

#15592 closed defect (duplicate)

src/test/ntor_ref.py client_part2() doesn't check AUTH matches server response

Reported by: joelanders Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Line 285:

    badness = my_auth != their_auth
    badness = bad_result(yx) + bad_result(bx)

    if badness:
        return None

Second line probably oughta be badness |= ....

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by joelanders

bleh this is a dupe of the previous one.

comment:2 Changed 5 years ago by joelanders

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.