Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15603 closed defect (not a bug)

Newnym does not change curcuit

Reported by: vpdevel Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.5.11
Severity: Keywords: newnym
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I check circuits via getinfo circuit-status after sending NEWNYM signal it seems that tor doesn't change the circuit at all.

Steps to reproduce:

  1. Start tor with control port.
  2. Connect to control port, authenticate, setevents signal
  3. Repeat getinfo circuit-status and signal newnym
  4. During that, make no requests through tor.

Example log attached.

I thought that response 650 indicates that circuit was successfully changed.

Child Tickets

Attachments (1)

log.txt (4.3 KB) - added by vpdevel 4 years ago.
test log

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by vpdevel

Attachment: log.txt added

test log

comment:1 Changed 4 years ago by gk

Component: - Select a componentTor

comment:2 Changed 4 years ago by yawning

Resolution: not a bug
Status: newclosed
  1. During that, make no requests through tor.

From control-spec.txt:

      NEWNYM    -- Switch to clean circuits, so new application requests
                   don't share any circuits with old ones.  Also clears
                   the client-side DNS cache.  (Tor MAY rate-limit its
                   response to this signal.)

This might need clarification, but the emphasis is on "new application requests". Until a new application request happens, there isn't going to be a visible effect. There's no explicit need to tear down old circuits, since they won't be used to service new requests.

comment:3 Changed 4 years ago by vpdevel

Any way to force it? E.g. for exit-node ip blacklisting utility?

Note: See TracTickets for help on using tickets.