Opened 5 years ago

Closed 5 years ago

#15655 closed defect (not a bug)

Revision hash is not present in the Tor repository.

Reported by: cypherpunks Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: gk, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The revision hash of the Tor version included in the Tor Browser Bundle is not present in the Tor repository.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by mcs

Status: newneeds_information

Which version of Tor Browser has this problem? I checked 4.5a5 and 4.0.8 and the hashes contained in TorBrowser/Docs/sources/bundle.inputs are in the Tor repo (https://git.torproject.org/tor.git)

comment:2 Changed 5 years ago by cypherpunks

I mean the revision shown by Tor when starting the Tor Browser within a terminal.
For example Tor v0.2.5.12 (git-xxxxxx) running on Linux with Libevent 2.0.21-stable, OpenSSL 1.0.1m and Zlib 1.2.8. where xxxxxx is the non-existing revision.

comment:3 in reply to:  2 Changed 5 years ago by mcs

Cc: gk mikeperry added

Replying to cypherpunks:

I mean the revision shown by Tor when starting the Tor Browser within a terminal.

Thanks for clarifying. I see this problem with both TB 4.5a5 and TB 4.0.8. But I cannot explain it.

comment:4 Changed 5 years ago by gk

Resolution: not a bug
Status: needs_informationclosed

The problem is that we are still not taking a vanilla tor tag due to missing patches in mainline tor (it got better but is still not perfect, i.e. patch-free). See for example: https://gitweb.torproject.org/builders/tor-browser-bundle.git/tree/gitian/descriptors/linux/gitian-tor.yml?h=maint-4.0.

Note: See TracTickets for help on using tickets.