Opened 5 years ago

Closed 5 years ago

#15688 closed defect (not a bug)

sdk/tabs

Reported by: mabe Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability
Cc: gk, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am writing a small Addon for the Tor Browser. I noticed that sdk/tabs is not working (Tor Browser 4.0.8 on Linux x64).

This small code example returns the number of all open tabs:

main.js

var tabs = require("sdk/tabs");
console.log(tabs.length);

When started in Vanilla Firefox with one open tab, it returns "1". In Tor Browser it always gives 0, no matter how many tabs are open.

I came to this simple example after I noticed that attaching content scripts to tabs didn't work either, which did in Vanilla Firefox just fine. It seems that the whole sdk/tabs class is not working at all.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by mabe

Component: - Select a componentTor Browser
Owner: set to tbb-team

comment:2 Changed 5 years ago by gk

Cc: gk added
Keywords: tbb-usability added

Trying with a timeout to check for race conditions on start-up does not work either. After 5 seconds tabs.length is still 0.

comment:3 Changed 5 years ago by mabe

PS: I noticed another difference in the behaviour of TBB and Vanilla Firefox: In Firefox the tabs.open() method opens another tab in the existing window (as expected), but in TBB it opens the tab in a new (second) window.

comment:4 Changed 5 years ago by mcs

Cc: mcs added

comment:5 Changed 5 years ago by mabe

I found that enabling the browser history solves the problem.

comment:6 in reply to:  5 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed

Replying to mabe:

I found that enabling the browser history solves the problem.

Aha, I guess this holds as well for a vanilla Firefox (i.e. disabling history breaks it there, too)? If not, please reopen this bug.

Note: See TracTickets for help on using tickets.