Opened 4 years ago

Closed 3 years ago

#15707 closed defect (not a bug)

Tonga isn't deduplicating bridge-server-descriptors anymore

Reported by: isis Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Normal Keywords: bridgedb-parsers, bridge, TorCoreTeam201608
Cc: Lucky, isis, yawning, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The BridgeAuthority used to deduplicate @type bridge-server-descriptors (but not @type bridge-extrainfos). It isn't doing either now.

I can fix this on BridgeDB, trivially, because I've already got the bridgedb.parse.descriptors.deduplicate() function for handling the extrainfos. Or… perhaps this was broken somehow during #14797 when we moved BridgeDB to polyanthum, like perhaps something was changed on Tonga? We could fix it on BridgeDB or Tonga, I have no preference; feel free to change the Component to something that makes more sense.

Child Tickets

Change History (7)

comment:1 Changed 4 years ago by yawning

Cc: yawning added; Yawning removed

comment:2 Changed 4 years ago by isis

This problem perhaps has been going on for longer than I previously thought. If so, it might have also been part of the cause for #12676.

comment:3 Changed 4 years ago by shamrock

Let me know what, if anything, I should change on Tonga...

comment:4 Changed 4 years ago by arma

I don't think Tonga ever deduplicated bridge descriptors. That's not what Tor does.

The networkstatus file specifies the descriptor that it's talking about, and you can find that descriptor in the cached-descriptors files.

That is, Tonga just copies over its cached descriptor files, which includes older versions of the descriptors too. This is normal and expected.

comment:5 Changed 4 years ago by arma

isis, should we close this ticket?

comment:6 Changed 3 years ago by isis

Keywords: TorCoreTeam201608 added

Adding to my august tickets.

comment:7 in reply to:  5 Changed 3 years ago by isis

Resolution: not a bug
Severity: Normal
Status: newclosed

Replying to arma:

isis, should we close this ticket?


Yes.

Note: See TracTickets for help on using tickets.