Opened 4 years ago

Closed 4 years ago

#15718 closed defect (invalid)

Firefox popups disappear on first click

Reported by: sajolida Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: tchou@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To reproduce this bug:

  1. Visit https://pad.riseup.net/p/torbrowserbug
  2. When the popup about HTML5 canvas appears, click anywhere on your desktop, for example to switch window or switch tab.
  3. This first click doesn't do the intended action but instead closes the popup about HTML5 canvas without you acting on it.

This also happens with other kind of popups, for example when installing and downloading extensions.

I discovered this bug while working the UX of the Tails verification extension for Firefox (https://tails.boum.org/blueprint/bootstrapping/extension/) where I believe this bug could lead to great confusion.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by sajolida

Summary: Firefox popups disappears on first clickFirefox popups disappear on first click

comment:2 Changed 4 years ago by mcs

For better or worse, those popups act like popup menus and other temporary windows. This is just how Firefox does things. Why is this a serious issue for the Tails verification extension?

comment:3 Changed 4 years ago by sajolida

Resolution: invalid
Status: newclosed

I checked again with normal Firefox and it works similarily. I should have done this from the beginning, sorry. I'm now closing this ticket as invalid.

Note: See TracTickets for help on using tickets.