Opened 4 years ago

Closed 4 years ago

#15734 closed defect (duplicate)

ftp pages are not isolated by first party in the cache

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-linkability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arthuredelstein)

I noticed that if I load
http://arthuredelstein.github.io/tordemos/ftp-in-iframe.html
and
http://arthurtordemos.github.io/tordemos/ftp-in-iframe.html
in two different tabs, then I can see that the ftp document,
ftp://ftp.mozilla.org/pub/mozilla.org/
in about:cache. It says "Fetch count: 2" and "No expiration time."

The behavior is inconsistent. Sometimes it looks as though there is only one network fetch, and sometimes two. Also, the ftp page sometimes disappears from the cache after a short while, which makes me think "no expiration time" means "expires pretty soon". The quick expiration means this is likely not a great linking vector, but I guess it's probably better to key ftp page caching by url bar domain.

Child Tickets

Change History (3)

comment:1 Changed 4 years ago by arthuredelstein

Description: modified (diff)

comment:2 Changed 4 years ago by gk

Status: newneeds_information

Is this a duplicate of #7561? Btw. I plan to rip the FTP cache part out during the ESR 38 cycle.

comment:3 Changed 4 years ago by arthuredelstein

Resolution: duplicate
Status: needs_informationclosed

Woops, yes it is. Strange that I even apparently added my name to it in March...

Note: See TracTickets for help on using tickets.