Opened 5 years ago

Closed 5 years ago

#15748 closed enhancement (not a bug)

feature request for discussion

Reported by: tada Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

thanks for the hard work. I got a few questions that may or may not turn into viable features. for your consideration... pls bear with me if this is in the wrong section

1) if the is so much interception of internet traffic worldwide, is it not more practical to make obfsproxy a default startup setting to reduce the potential amount of attention from spying idiots

2) with the growing anti-NSA sentiment, has tor though about approving at least one geoip plugin like WORLDIP, so folk who are super weary can see where at website is located and if need be block an entire country if they feel their privacy is at threat

3) with tors infrastructure pretty well established, there is still no way to verify that when you visit tor it is not a NSA dummy site. Is it possible to implement a verification site that sits as a hidden service that holds some kind of session key, giving lets say the tor site a ring-of-three auth model. so when a client visits tor, it has to fetch an session key from a hidden service, so that the NSA's clever faster-than-light tactic can be circumvented.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed

I think discussing these things on our mailing lists (e.g. tor-talk) is a fine thing to do. This is our bug tracker to get actual development coordinated. If your discussion ends up with things we should implement then this is the place to get the technical details hashed out afterwards.

Note: See TracTickets for help on using tickets.