Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#15761 closed defect (not a bug)

Bridges stop working when UseBridges is set

Reported by: qbi Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.6.7
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by qbi)

Tor's Q&A page has a question where someone uses bridges and ExitNodes and can't get a connection. So I tried to reproduce it:

  1. Retrieve some bridges (with obfs3 in this case) and enter them into torrc.
  2. Set ExitNodes {US}
  3. restart Tor and everything is fine.
  4. Add UseBridges 1 and restart Tor.

Now Tor can't get a connection anymore. I see the following log message every second:

Apr 21 19:05:42.000 [info] should_delay_dir_fetches(): Delaying dir fetches (no running bridges known)
Apr 21 19:05:42.000 [info] compute_weighted_bandwidths(): Empty routerlist passed in to consensus weight node selection for rule weight as guard

When I remove UseBridges and restart Tor everything is fine.

While trying to tracking it down I figured out that ExitNodes doesn't play a role here. A minimal non-working torrc just needs a ClientTransportPlugin, some obfs3 bridges and UseBridges.

Child Tickets

Change History (10)

comment:1 Changed 4 years ago by qbi

I also tested it with plain bridges and can't reproduce it. So far it is only working with obfs3, but I haven't tested other transports.

comment:2 Changed 4 years ago by arma

Yeah, it sounds like hearing the exact torrc entries will help us track this one down. There's too much variability in the report as stated.

comment:3 Changed 4 years ago by qbi

I tried to create a minimal torrc. I did my tests with Tor v0.2.6.7 (git-c1a17aafcc854762) installed as Debian package.

Working configuration:

ClientTransportPlugin obfs3 exec /path/to/PluggableTransports/obfsproxy.bin managed
bridge  obfs3 IP1:PORT1 FP1
bridge  obfs3 IP2:PORT2 FP2
bridge  obfs3 IP3:PORT3 FP3

non-working configuration:

UseBridges 1
ClientTransportPlugin obfs3 exec /path/to/PluggableTransports/obfsproxy.bin managed
bridge  obfs3 IP1:PORT1 FP1
bridge  obfs3 IP2:PORT2 FP2
bridge  obfs3 IP3:PORT3 FP3

comment:4 Changed 4 years ago by qbi

Description: modified (diff)
Summary: UseBridges and ExitNodes don't play togetherBridges stop working when UseBridges is set

comment:5 Changed 4 years ago by teor

Milestone: Tor: 0.2.???

comment:6 Changed 4 years ago by arma

Severity: Normal

Well, as specified, this is not surprising. When UseBridges is 0, Tor ignores the other lines.

So basically, your bug is that when you try to use those three bridges, Tor doesn't work for you.

Are you super sure that those three bridges were working bridges? :)

comment:7 Changed 3 years ago by arma

Status: newneeds_information

Setting to needs-information, and if some time passes and qbi doesn't clarify, we should close.

comment:8 Changed 3 years ago by qbi

Resolution: not a bug
Status: needs_informationclosed

I tried to reproduce the "bug" with the current git master. However it worked whenever the bridges were working and valid. So I'll close this report.

comment:9 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:10 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.