Opened 4 years ago

Closed 4 years ago

#15787 closed defect (fixed)

HTTPS Everywhere 5.0.3 breaks rottentomatoes.com: HD videos don't play

Reported by: cypherpunks Owned by:
Priority: Immediate Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: rottentomatoes.com
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Error message: "Cannot load M3U8: 404 not found"

Child Tickets

Change History (7)

comment:1 Changed 4 years ago by jsha

You should upgrade to the latest version, 5.0.2. Is your install not auto-updating?

comment:2 Changed 4 years ago by jsha

Resolution: worksforme
Status: newclosed

comment:3 Changed 4 years ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Version 5.0.2 breaks gamespot.com, so updating isn't a solution.

comment:4 Changed 4 years ago by jsha

Can you confirm whether rottentomatoes works for you on the latest version? We will address the gamespot issues separately in https://trac.torproject.org/projects/tor/ticket/15656.

comment:5 Changed 4 years ago by cypherpunks

Summary: HTTPS Everywhere 4.0.3 breaks rottentomatoes.com: HD videos don't playHTTPS Everywhere 5.0.3 breaks rottentomatoes.com: HD videos don't play

Still get the same error message with HTTPS Everywhere 5.0.3.

comment:6 Changed 4 years ago by jsha

I'm afraid I still can't reproduce the problem.

Is the rotten tomatoes rule enabled or disabled in your install? It should now be disabled by default, but if you've toggled it off or on in the past, the extension will override the default value.

comment:7 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: reopenedclosed

It works with HTTPS Everywhere 5.0.4.

Note: See TracTickets for help on using tickets.