Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15800 closed defect (not a bug)

Unable to disable proxy in Tor Browser

Reported by: supermario Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: brade, mcs, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm trying to use tor browser for normal browsing, in other words I'm not going through tor. I want to use tor browser just for the privacy it offers. I am unable to disable the proxy. When I do I get this error message:

Unable to find the proxy server
Firefox is configured to use a proxy server that can't be found.

It happens if I have it set to no proxy or I have it set to manual proxy but with everything blank.

As a workaround I created a proxy on my machine and set the tor browser to that proxy. My use may be rare but it seems like a good idea to make the Tor Browser work for people who just want the enhanced privacy, but not necessarily to send their traffic over tor.

If this is not a bug could add a setting like "network.proxy.tor_proxy_not_required" that would let me use Tor Browser without a proxy. Thanks

Child Tickets

Change History (6)

comment:1 Changed 4 years ago by mcs

Cc: brade mcs added

What version of Tor Browser are you using?
What settings did you modify?

One possible solution is to use about:config to set the following preferences values:

extensions.torlauncher.start_tor = false
network.proxy.type = 0
network.proxy.socks_remote_dns = false

But note that the about:tor page (the default home page) will complain that Tor is not working. Also note that in Tor Browser 4.5 some Torbutton security features may be disabled until #15852 is fixed.

comment:2 Changed 4 years ago by supermario

Thanks mcs. It's the setting network.proxy.socks_remote_dns. Even when I am not using a proxy if that is set to true I get the proxy not found message. When I use normal firefox that setting does not seem to matter when proxy is disabled. Is that a bug?

comment:3 in reply to:  2 Changed 4 years ago by mcs

Cc: mikeperry added

Replying to supermario:

Thanks mcs. It's the setting network.proxy.socks_remote_dns. Even when I am not using a proxy if that is set to true I get the proxy not found message. When I use normal firefox that setting does not seem to matter when proxy is disabled. Is that a bug?

It is because of the fix we made for #5741.
https://gitweb.torproject.org/tor-browser.git/commit/?h=tor-browser-31.6.0esr-4.5-1&id=8c6604d2b776f0d8e33ed9130c5f5b8cf744bac8
We could check that a proxy is enabled (network.proxy.type != 0) before disabling DNS but we can also just make sure people know to set network.proxy.socks_remote_dns to false.

comment:4 Changed 4 years ago by gk

I think knowing to set network.proxy.socks_remote_dns to false should be enough given this rare use-case which is actually outside of the design specified by the Tor Browser design document.

comment:5 in reply to:  4 Changed 4 years ago by mcs

Resolution: not a bug
Status: newclosed

Replying to gk:

I think knowing to set network.proxy.socks_remote_dns to false should be enough given this rare use-case which is actually outside of the design specified by the Tor Browser design document.

OK; I agree. Closing this ticket.

comment:6 Changed 4 years ago by supermario

Although I know now if you aren't going to change the behavior I suggest you add something for other users to the Connection Settings below remote DNS that says disabling proxy use does not work unless remote DNS is also disabled.

Note: See TracTickets for help on using tickets.