Opened 5 years ago

Closed 5 years ago

#15811 closed defect (duplicate)

onionoo instances disagree on last_restarted

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A478E421F83194C114F41E94F95999672AED51FE from relays_published 2015-04-25 08:00:00

tpo:
"2015-02-26 22:48:09"

tct:
"2015-02-26 22:48:10"

I assume last restarted is calculated via published [1] - uptime [2] values
from the descriptor, so if instances process the same descriptor they should come to the same conclusion even if the local system time of the onionoo instance is incorrect, no?

[1] https://gitweb.torproject.org/torspec.git/tree/dir-spec.txt#n401
[2] https://gitweb.torproject.org/torspec.git/tree/dir-spec.txt#n430

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by karsten

Resolution: duplicate
Status: newclosed

That's correct, this calculation does not depend on the local system time of Onionoo, but only on the two mentioned fields.

It looks like those last-restarted times were calculated based on two different descriptors:

router DFRI4 171.25.193.78 443 0 80
published 2015-04-24 16:19:21
uptime 4901472
-> 2015-02-26 22:48:09

router DFRI4 171.25.193.78 443 0 80
published 2015-04-25 07:12:55
uptime 4955085
-> 2015-02-26 22:48:10

I think that makes this ticket a duplicate of #15809. Closing. Please re-open if you think it's a different issue.

Note: See TracTickets for help on using tickets.