Opened 4 years ago

Closed 4 years ago

#15818 closed defect (fixed)

chutney verify hangs on tor hs data transmission verification

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7
Severity: Keywords:
Cc: dgoulet, andrea, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by teor)

chutney hs verify hangs under the latest tor 0.2.7-alpha-dev.
Verification of clients, exits, bridges and IPv6 bridges works fine.

hs verify worked in 01d988d72f9eae798a36d1c8bb226b9e8f4fe3f1 (after teor/bug-15642-v3-fallback-unit-tests was merged), but now hangs in 63a90f2df4dcd7fff862ca3849f3aa3b1dec7e84.

This may be due to:

which were merged in between those commits.

It worries me that we may have broken hidden services, so I have listed this as "critical".

I'll look into this when I get time in the next day or two, but I wanted to log the bug so everyone knew about it.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by teor

Description: modified (diff)
Status: newneeds_information

typos, status

comment:2 Changed 4 years ago by teor

Priority: criticalnormal

I can't see how any of these changes could have broken hs verification in chutney.
Only dgoulet's changes even had anything to do with HS, and they were only controller changes.
This could be a chutney problem.

Downgrading to normal, leaving with tor until it's clear where the issue is.

comment:3 Changed 4 years ago by yawning

It's probably #15816.

comment:4 Changed 4 years ago by teor

Yes, #15816 would explain the exact behaviour I'm seeing: the verification hangs.
Except that it hangs indefinitely, not for 15 minutes. But that may be because chutney gives up internally, but doesn't throw an error.

comment:5 Changed 4 years ago by teor

Resolution: fixed
Status: needs_informationclosed

chutney verify on hidden services now works with git 6ed57331695bee98f408d99c60684aaadcfe9a43

Note: See TracTickets for help on using tickets.