Opened 4 years ago

Closed 4 years ago

#15824 closed defect (implemented)

Silly ambiguous function names in rendservices

Reported by: special Owned by:
Priority: Very Low Milestone: Tor: 0.2.7.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-hs lorax
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

rendservices.c has two functions:

rend_services_introduce
rend_service_introduce

One of these is called every second to consider adding new intro points to our services. The other one is called to handle an inbound INTRODUCE2 cell for a service.

I suggest renaming them to something like:

rend_consider_services_intro_points
rend_service_receive_introduction

Also worth noting that rend_service_validate_intro_early does nothing (/* TODO */).

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by nickm

seems okay to me.

comment:2 Changed 4 years ago by dgoulet

Yes yes and yes! :)

comment:3 Changed 4 years ago by nickm

Keywords: lorax added

comment:4 Changed 4 years ago by special

Milestone: Tor: 0.2.7.x-final
Status: newneeds_review

comment:5 Changed 4 years ago by nickm

Resolution: implemented
Status: needs_reviewclosed

merged it!

Note: See TracTickets for help on using tickets.