Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#15872 closed defect (fixed)

Meek doesn't start in Tor Browser 4.5 on Windows 7

Reported by: zazone2002 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability, tbb-4.5-regression, meek
Cc: dcf, gk, mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I downloaded the tor browser 4.5 and installed on a Dell computer with windows 7 ultimate 64bit.
when I use meek and start the browser , it just stuck in the connecting process, and 10 minute past. no attention mark or anything turned up.(even the button to copy log didn't show up)

the strange thing is meek-client-torbrowser.exe and meek-client.exe don't start. I can's see them in the task manager.other things like obfs and fte all work fine.
I tried a fresh install and creating a new account,but it doesn't work either.
However the tor browser works perfect on a computer with windows 8.1 64bit.
Meanwhile the torbrowser 4.0.8 works fine on both computers.

Child Tickets

Attachments (1)

Image 1.png (68.6 KB) - added by zazone2002 22 months ago.
nothing turned up with stuck.

Download all attachments as: .zip

Change History (11)

Changed 22 months ago by zazone2002

nothing turned up with stuck.

comment:1 Changed 22 months ago by zazone2002

I tried again with tor browser 4.5 on another computer with windows 7 home premium 64 bit, but still no luck, meek still didn't work.

comment:2 Changed 22 months ago by gk

  • Cc dcf gk added
  • Keywords tbb-usability tbb-4.5-regression added
  • Milestone Tor: 0.2.??? deleted
  • Version Tor: 0.2.6.7 deleted

comment:3 Changed 22 months ago by mcs

  • Cc mcs added

comment:4 Changed 22 months ago by mcs

  • Cc brade added

Some quick tests show that meek works OK in TB 4.5 on Mac OS. On Windows 7 Pro 32-bit, it works for me in TB 4.5a5 but not with TB 4.5.

comment:5 follow-up: Changed 22 months ago by dcf

  • Keywords meek added

It look like this is because of #15606 (itself a result of #15435), which made the programs work with the new TOR_PT_EXIT_ON_STDIN_CLOSE convention. The bug is stdin.Close() here:

https://gitweb.torproject.org/pluggable-transports/meek.git/diff/?id=0.17&id2=0.16

That call doesn't make any sense, because the purpose of the program is to keep the subprogram's stdin open. I tested without it, and meek bootstraps on Windows 7. I'll make a new release without it.

Of course I tested that change on Windows. But I tested on Windows 8, not Windows 7. Now I wonder why it works on Windows 8! Is Tor Browser 4.5 built with the patch from #15435?

The clue to what was going wrong was the meek-client-torbrowser log:

2015/04/30 20:02:12 meek-client started with pid 3128
2015/04/30 20:02:12 synthesizing SIGTERM because of stdin close
2015/04/30 20:02:12 sig terminated
2015/04/30 20:02:12 sending signal terminated to PID 3128

comment:6 in reply to: ↑ 5 Changed 22 months ago by gk

Replying to dcf:

Of course I tested that change on Windows. But I tested on Windows 8, not Windows 7. Now I wonder why it works on Windows 8! Is Tor Browser 4.5 built with the patch from #15435?

No.

comment:7 Changed 22 months ago by dcf

I tagged meek 0.18 with this change. I created #15902 for the upgrade.

comment:8 Changed 22 months ago by isis

  • Summary changed from the meek doesn't start with the torbrowser 4.5 to Meek doesn't start with the Tor Browser 4.5

comment:9 Changed 22 months ago by mikeperry

  • Resolution set to fixed
  • Status changed from new to closed

It looks like we merged the 0.18 tag update already. Thanks, dcf!

comment:10 Changed 22 months ago by dcf

  • Summary changed from Meek doesn't start with the Tor Browser 4.5 to Meek doesn't start in Tor Browser 4.5 on Windows 7
Note: See TracTickets for help on using tickets.