Opened 4 years ago

Closed 4 years ago

#15891 closed defect (not a bug)

Wrong address tested for reachability

Reported by: tmpname0901 Owned by:
Priority: Medium Milestone: Tor: 0.2.6.x-final
Component: Core Tor/Tor Version: Tor: 0.2.6.7
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After displaying the correct IP address, as read from the relay config file, Tor attempts to verify the reachability of a different address. See below.

I have no idea where this bogus 198.105.254.68 address is coming from. The last line below is followed by a stream of warnings that 198.105.254.68:9001 and 198.105.254.68:9030 cannot be reached. No surprise there, as it is not the address I specified.


May 01 11:38:09.000 [notice] Tor 0.2.6.7 (git-9ccf019b168909ef) opening log file.
May 01 11:38:09.933 [notice] Tor v0.2.6.7 (git-9ccf019b168909ef) running on Linux with Libevent 2.0.22-stable, OpenSSL 1.0.1m and Zlib 1.2.8.
May 01 11:38:09.933 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
May 01 11:38:09.933 [notice] Read configuration file "/etc/tor/torrc".
May 01 11:38:09.937 [notice] Your ContactInfo config option is not set. Please consider setting it, so we can contact you if your server is misconfigured or something else goes wrong.
May 01 11:38:09.937 [notice] Based on detected system memory, MaxMemInQueues is set to 747 MB. You can override this by setting MaxMemInQueues by hand.
May 01 11:38:09.938 [notice] Opening Socks listener on 127.0.0.1:9050
May 01 11:38:09.938 [notice] Opening OR listener on 216.218.216.197:9001
May 01 11:38:09.938 [notice] Opening OR listener on [2001:470:1:2f9:0:1:fbc:16ed]:9001
May 01 11:38:09.938 [notice] Opening Directory listener on 216.218.216.197:9030
May 01 11:38:09.000 [warn] Failed to unlink /var/lib/tor/bw_accounting: No such file or directory
May 01 11:38:10.000 [notice] Your Tor server's identity key fingerprint is 'Unnamed 2C34FB27A21F0C9EAA2ADA0C2D72EB49F72C975A'
May 01 11:38:10.000 [notice] Configured hibernation. This interval begins at 2015-04-30 00:00:00 and ends at 2015-06-01 00:00:00. We have no prior estimate for bandwidth, so we will start out awake and hibernate when we exhaust our quota.
May 01 11:38:10.000 [notice] Parsing GEOIP IPv4 file /usr/share/tor/geoip.
May 01 11:38:10.000 [notice] Parsing GEOIP IPv6 file /usr/share/tor/geoip6.
May 01 11:38:10.000 [notice] Configured to measure statistics. Look for the *-stats files that will first be written to the data directory in 24 hours from now.
May 01 11:38:10.000 [notice] Bootstrapped 0%: Starting
May 01 11:38:11.000 [notice] Bootstrapped 80%: Connecting to the Tor network
May 01 11:38:13.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
May 01 11:38:13.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
May 01 11:38:14.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
May 01 11:38:14.000 [notice] Bootstrapped 100%: Done
May 01 11:38:14.000 [notice] Now checking whether ORPort 198.105.254.68:9001 and DirPort 198.105.254.68:9030 are reachable... (this may take up to 20 minutes -- look for log messages indicating success)

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by tmpname0901

Once more thing. Despite the series of "has not managed to confirm" warnings in the log file specifying the wrong address, I actually can get to the Tor network via the local SOCKS port.

comment:2 Changed 4 years ago by tmpname0901

More info:

May 03 04:58:12.000 [warn] Your server (198.105.254.68:9030) has not managed to confirm that its DirPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.
May 03 05:05:04.000 [notice] Your IP address seems to have changed to 216.218.216.197 (METHOD=INTERFACE). Updating.
May 03 05:05:04.000 [notice] Our IP Address has changed from 198.105.254.68 to 216.218.216.197; rebuilding descriptor (source: METHOD=INTERFACE).
May 03 05:05:05.000 [notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
May 03 05:05:11.000 [notice] Performing bandwidth self-test...done.
May 03 05:05:59.000 [notice] Your IP address seems to have changed to 198.105.254.68 (METHOD=GETHOSTNAME HOSTNAME=bridgB2). Updating.
May 03 05:05:59.000 [notice] Our IP Address has changed from 216.218.216.197 to 198.105.254.68; rebuilding descriptor (source: METHOD=GETHOSTNAME HOSTNAME=bridgB2).
May 03 05:25:59.000 [warn] Your server (198.105.254.68:9001) has not managed to confirm that its ORPort is reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.

comment:3 in reply to:  2 Changed 4 years ago by yawning

Status: newneeds_information

Replying to tmpname0901:

May 03 05:05:59.000 [notice] Your IP address seems to have changed to 198.105.254.68 (METHOD=GETHOSTNAME HOSTNAME=bridgB2). Updating.
May 03 05:05:59.000 [notice] Our IP Address has changed from 216.218.216.197 to 198.105.254.68; rebuilding descriptor (source: METHOD=GETHOSTNAME HOSTNAME=bridgB2).

This sort of explains it by itself. Among other methods, tor uses gethostname() to guess the IP address. In your case, your computer's hostname apparently is bridgB2, with the IP address 198.105.254.68. This would be a configuration problem on your system (I would suspect something along the lines of a invalid /etc/hosts entry or perhaps a incorrect DNS config.

The Address directive in torrc exists to work around situations where "having a hostname that reflects reality, with an IP address that is public" is not possible.

Please double check your system's configuration.

comment:4 Changed 4 years ago by tmpname0901

Resolution: not a bug
Status: needs_informationclosed

You're absolutely right, it was a missing /etc/hosts entry. Thanks for pulling my head out.

Note: See TracTickets for help on using tickets.