Opened 4 years ago

Closed 10 months ago

Last modified 10 months ago

#15897 closed defect (worksforme)

Circuit Information is not displayed on Firefox error pages

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, tbb-circuit-display, tbb-usability
Cc: arthuredelstein, gk, arma, mcs, special Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The issue
Circuit information is not displayed on Firefox error pages "Untrusted Connection" or "Problem Loading Page".

Why does that matter?
User encounters a suspicious SSL error:

  • User can no longer visit an IP discovery website because Tor Browser will use a different circuit and,
  • Tor Browser does not display the circuit information.

It's then difficult for the user to determine which exit they were using when they encountered the suspicious behavior.

This obstacle might ultimately prevent users from investigating suspicious exits or making BadExit reports to Tor.

Recreation/Versions

Behavior described can be observed at https://mjvmobile.com.br/ (SSL error) or any domain that wont load. Clicking TorButton does not display circuit information while on the error page.

This happens reliably with Tor Browser 4.5 (Windows).

Child Tickets

Change History (23)

comment:1 Changed 4 years ago by gk

Cc: arthuredelstein gk added
Keywords: tbb-torbutton tbb-circuit-display tbb-usability added; SSL Certificate Untrusted Connection removed

comment:2 Changed 4 years ago by arthuredelstein

Here's a patch for this ticket.
https://github.com/arthuredelstein/torbutton/commit/69ed9aa24d42d2d36f281de6353db628b59c4240

I changed the circuit display to update whenever a tab initiates the first connection for a new page. So the tor circuit is displayed earlier (roughly as soon as it is available) and also remains visible if the connection fails and an error page is shown by the browser.

This patch also re-organizes the tor-circuit-display.js file, but most functions are not changed.

Last edited 4 years ago by arthuredelstein (previous) (diff)

comment:3 Changed 4 years ago by arthuredelstein

Keywords: TorBrowserTeam201505R added
Status: newneeds_review

comment:4 Changed 4 years ago by gk

Keywords: GeorgKoppen201505R added

comment:5 Changed 4 years ago by gk

Looks good to me. I am a bit confused about the setTimeout() call. Why do we need it? And we are not introducing hard to debug race conditions, right? *grin* Could you add a comment in the code on the reason why we have to use it?

comment:6 Changed 4 years ago by gk

Status: needs_reviewneeds_revision

Hrm... it seems I can reliably reproduce cases where the circuit display is not shown anymore at all with this patch. One is: Sec slider -> high and loading spiegel.de. Not sure why this happens yet.

comment:7 in reply to:  6 Changed 4 years ago by arthuredelstein

Replying to gk:

Hrm... it seems I can reliably reproduce cases where the circuit display is not shown anymore at all with this patch. One is: Sec slider -> high and loading spiegel.de. Not sure why this happens yet.

I also see this with the Security Slider set to low. Looks like this has to do with a redirect from spiegel.de -> www.spiegel.de. I'm working on a fix.

comment:8 Changed 4 years ago by gk

#15983 is a duplicate.

comment:9 Changed 3 years ago by gk

Keywords: TorBrowserTeam201505 added; TorBrowserTeam201505R GeorgKoppen201505R removed

comment:10 Changed 3 years ago by mikeperry

Keywords: TorBrowserTeam201505 removed

comment:11 Changed 3 years ago by gk

Cc: arma added
Severity: Normal

Marked #17373 as duplicate.

comment:12 Changed 3 years ago by mcs

Cc: mcs added

comment:13 Changed 3 years ago by gk

Cc: special added

Closed #18724 as duplicate.

comment:14 Changed 2 years ago by bugzilla

Summary: Circuit Information is not displayed on Firefox error pagesCircuit information is not displayed on Tor Browser new/error pages

Closed #18122 as a duplicate, because it needs the same solution as this ticket (comment:2). And its part about performance is the same as #18859.

comment:15 Changed 2 years ago by mcs

Closed #20503 a duplicate.

comment:16 Changed 22 months ago by cypherpunks

I would like to report another problem that seems to be related, when a website doesn't load due to a problem with the current circuit I have to wait until it stops trying to load the page to be able to use "New Tor Circuit for this Site". I wish this could be improved so I could use this button while it is still trying to load the page as this is the time I need to use this feature the most. If I manually stop loading the page, "new tor circuit" option doesn't work

easiest way to see what I mean is to try loading a non-existent onion page like: http://wwwwwwwwwwwwwwww.onion/

if you try new tor circuit for this page in the middle of loading, it stops everything and doesn't help

Last edited 22 months ago by cypherpunks (previous) (diff)

comment:17 Changed 19 months ago by cypherpunks

Surprisingly, TBB 7.0a3 shows circuits while trying to load page in the description, even though connections ended with REMOTE_REASON=RESOLVEFAILED. Seems ff52 spoofs torbutton (status bar shows "connected" for the site), but loads the site forever (bug).

comment:18 in reply to:  16 Changed 19 months ago by cypherpunks

Replying to cypherpunks:

if you try new tor circuit for this page in the middle of loading, it stops everything and doesn't help

It's because URL of the tab continues to be about:blank. It's better to file a new ticket for this issue.

comment:19 Changed 12 months ago by gk

Resolution: worksforme
Status: needs_revisionclosed

This seems to work for me, right now. (Using a custom Tor Browser 7.5a8) The issue in comment:16 seems to be related to #22538.

comment:20 Changed 10 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Doesn't work for me in 7.5a10 on new tabs.

comment:21 in reply to:  20 Changed 10 months ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to cypherpunks:

Doesn't work for me in 7.5a10 on new tabs.

New tabs don't have domains in their URL bar. Thus, that behavior is expected.

comment:22 in reply to:  description ; Changed 10 months ago by cypherpunks

Summary: Circuit information is not displayed on Tor Browser new/error pagesCircuit Information is not displayed on Firefox error pages

Bleh.
Not expected, but as you insist, restoring the tickets...
Also it doesn't work for URL in comment:16, still has comment:17 and comment:18.

comment:23 in reply to:  22 Changed 10 months ago by gk

Replying to cypherpunks:

Bleh.
Not expected, but as you insist, restoring the tickets...
Also it doesn't work for URL in comment:16, still has comment:17 and comment:18.

What is expected instead if you are opening a new tab and look at the circuit display? You don't have any domain in your URL bar let alone started to load that one.

Note: See TracTickets for help on using tickets.