Opened 4 years ago

Closed 4 years ago

#15945 closed defect (fixed)

Disable NoScript ClickJack Protection

Reported by: mikeperry Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: TorBrowserTeam201505, tbb-usability, tbb-4.5-regression, tbb-pref
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Pending an actual fix for #14985, we need to disable NoScript's clickjacking, because it is currently broken in Tor Browser, and is the source of a lot of improper warnings and dialogs while clicking on elements (especially cloudflare captchas). This ticket is just for a bug number for tracking the workaround of disabling it, so we don't have to close #14985 (which has lots of good analysis details).

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by mikeperry

Keywords: tbb-pref added
Resolution: fixed
Status: newclosed

Ok, I merged this pref update for 4.5.1.

Note: See TracTickets for help on using tickets.