Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15947 closed defect (fixed)

Gitian fails to run in LXC mode on Ubuntu 14.04

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-gitian, TorBrowserTeam201505R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our Gitian setup fails to run in LXC mode on Ubuntu 14.04. I get the following error:

bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

Turns out to be https://github.com/devrandom/gitian-builder/issues/63 in fact.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by gk

Keywords: TorBrowserTeam201505R added
Status: newneeds_review

bug_15947 in my gitian-builder repo (https://gitweb.torproject.org/user/gk/gitian-builder.git/commit/?h=bug_15947&id=a681029fa1d0727e2082623a7d7c9937e95aa49c) has the backport of the fix. Old containers need to get replaced and we might need to change things on our LXC machine, too, in order to avoid the root requirement.

comment:2 Changed 5 years ago by gk

I added another backport on top of it (https://gitweb.torproject.org/user/gk/gitian-builder.git/commit/?h=bug_15947&id=0c046177c514f63a0f723959e0ef37333fcd9f71) which makes things easier and backwards compatible. I did not squash the commits to keep the history available.

comment:3 Changed 5 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

Ok, this looked OK to me, though I wonder how many 14.04 users will actually know to use the env var.

I merged it and tagged a new gitian-builder tag, and updated our versions files to use it for stable and alpha.

comment:4 Changed 5 years ago by gk

I'll update our HACKING document adding this bit I'll look into updating our README as well. That should be enough.

Oh, and #12431 is a duplicate of this bug I guess.

Note: See TracTickets for help on using tickets.