Opened 4 years ago

Closed 4 years ago

#15964 closed enhancement (duplicate)

Tor Launcher should notify users that their clock is not set correctly

Reported by: Sherief Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords: tbb-helpdesk-frequent, tbb-usability,
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Often the help desk gets tickets where users cannot connect due to incorrect date/time settings.

Currently, Tor Launcher doesn't give any feedback about the error. It would be great if Tor launcher detects the warning below and alerts the user they need to set their time and date correctly. It would be even better if it says the inaccuracy of time within the alert box.

Example log:
[WARN] Our clock is 21 hours, 17 minutes behind
the time published in the consensus network status document (2015-05-03
21:00:00 UTC). Tor needs an accurate clock to work correctly. Please check
your time and date settings!

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by mcs

Possibly a duplicate of #9675.

Was a "caution" icon displayed to encourage users to look at their Tor log?

comment:2 in reply to:  1 Changed 4 years ago by Sherief

Resolution: duplicate
Status: newclosed

Replying to mcs:

Possibly a duplicate of #9675.

Was a "caution" icon displayed to encourage users to look at their Tor log?

That is not really helpful since most users will be overwhelmed by the log. Closing.

comment:3 Changed 4 years ago by cypherpunks

If it's possible to do this, IMO, it should be done, with high priority.

Last edited 4 years ago by cypherpunks (previous) (diff)

comment:4 Changed 4 years ago by cypherpunks

Resolution: duplicate
Status: closedreopened

comment:5 Changed 4 years ago by cypherpunks

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.