Opened 4 years ago

Closed 3 years ago

#15981 closed defect (worksforme)

Message "Tor Browser is already running", when trying to open a link

Reported by: tot-to Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: tim@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When the torbrowser is normally running and I try to open another link from another application or from the command line, instead of openning the link in the running instance as it is usually the case for firefox, I can see a separate window with the following message:

Tor Browser is already running, but is not responding. To open a new window, you must first close the existing Tor Browser process, or restart your system.

If I close torbrowser and try to open the link again with closed browser, it opens just fine. But the second link makes the same window.

I found the similar bugreport #12941, but in that case the window appears when the browser is not running. It's never the case for me.

I use www-client/torbrowser-31.6.0_p450 from torbrowser Gentoo overlay.

Child Tickets

Change History (4)

comment:1 Changed 4 years ago by tsammut

Cc: tim@… added

I am seeing the same behavior in TBB 4.5.3.

Coincidentally I am also using Gentoo but with TBB downloaded directly from torproject.org not an overlay.

comment:2 Changed 4 years ago by karsten

Component: - Select a componentTor Browser
Owner: set to tbb-team

comment:3 Changed 3 years ago by cypherpunks

Severity: Normal

Try adding --allow-remote to your command line. For initial startup:
~/tor-browser/Browser/start-tor-browser --allow-remote

Then from another shell to pop a new window up:
~/tor-browser/Browser/start-tor-browser --allow-remote --new-window
Or with a URL:
~/tor-browser/Browser/start-tor-browser --allow-remote --new-window about:config

If this interferes with a system firefox, set a unique $LOGNAME for each profile, like "export LOGNAME=tor" before you run start-tor-browser.

comment:4 in reply to:  3 Changed 3 years ago by cypherpunks

Resolution: worksforme
Status: newclosed

Replying to cypherpunks:

If this interferes with a system firefox, set a unique $LOGNAME for each profile, like "export LOGNAME=tor" before you run start-tor-browser.

I believe that shouldn't happen anymore since the script passes a --class argument different than Firefox's.

Also closing this since the ticket is really old, the bug was fixed long ago, and the fix seems to work. Duplicates: #15185 #15370 #9344.

Note: See TracTickets for help on using tickets.