Opened 4 years ago

Closed 4 years ago

#15984 closed defect (fixed)

disabling Torbutton breaks the Add-ons manager

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-torbutton, TorBrowserTeam201505R, GeorgKoppen201505R
Cc: tot-to Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To reproduce, disable Torbutton and restart the browser. Then go to menu and click Add-ons. This error will show up:

XML Parsing Error: undefined entity
Location: about:addons
Line Number 359, Column 15:

<button class="button-plugin-disable"


So I cannot re-enable Torbutton from the browser

Child Tickets

Change History (7)

comment:1 in reply to:  description Changed 4 years ago by gk

Replying to cypherpunks:

So I cannot re-enable Torbutton from the browser

Well, you can from outside your browser if you delete the extensions.* files in your profile directory (but not the extensions directory) and restart.

That said what is this bug about? That one can disable Torbutton at all? That one cannot re-enable it within the browser? That an XML parsing error is shown?

comment:2 Changed 4 years ago by gk

Cc: tot-to added
Keywords: tbb-torbutton added

#15980 is a duplicate.

comment:3 Changed 4 years ago by cypherpunks

The problem is the inability to access the add-ons page, whether to re-enable torbutton or to manage other add-ons. Actually my purpose was to find a way to set custom proxy settings for Tor. Since those settings were removed from the Torbutton menu on last Tor Browser, I went to the browser's own network settings page and there it told me to disable Torbutton to change those settings. I think I could have done it using custom prefs but setting them manually sucks and I couldn't get it to work. And after disabling Torbutton, found this bug.

comment:4 Changed 4 years ago by mcs

Keywords: TorBrowserTeam201505R added
Status: newneeds_review

Kathy and I encountered this same bug last week. It is caused by the #10280 patch, which adds some entities to toolkit/mozapps/extensions/content/extensions.xul that are defined in Torbutton's brand.dtd file. Here is a two part fix:

https://gitweb.torproject.org/user/brade/tor-browser.git/commit/?h=bug15984-01&id=5b064c0ea1aff6b74c624ab6fbfed00fe93e4872

https://gitweb.torproject.org/user/brade/torbutton.git/commit/?h=bug15984-01&id=53f1a2cf0315ccd48f326227c20e51e136667558

comment:5 Changed 4 years ago by gk

#16078 is a duplicate.

comment:6 Changed 4 years ago by gk

Keywords: GeorgKoppen201505R added

comment:7 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

This looks good, thanks. I've modified the commit message for the Tor Browser patch a bit to get the fix autosquashed during rebase. Additionally, I've applied it to our stable branch as well as this regression fix is pretty low risk. 2f614ed514155e5473499c027054de8aea77e726 and 86997f5baac6c1f0de8c84145a048b65716b35e7 (4.5.1 and 5.0) and 53f1a2cf0315ccd48f326227c20e51e136667558 (Torbutton) are the respective commit hashes.

Note: See TracTickets for help on using tickets.