Opened 4 years ago

Closed 4 years ago

#16012 closed defect (fixed)

OS X TBB: escalating CPU usage when TBB can't connect

Reported by: DrMikeTwiddle Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version: Tor: unspecified
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This has been a problem for ages. It's as if TBB or Tor component of TBB can't kill its own loop and gets stuck in it if the circuit is not responding and the site won't load.

There is no contigency plan.

Fans start whirring CPU maxes out until tab or window loading is manually cancelled by user. TBB needs to guess what's happening and kill the loop it's stuck in before CPU usage maxes out.

Doesn't matter which version of TBB, all do this.

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by cypherpunks

Severity: Normal

This is a duplicate of #9659.

comment:2 Changed 4 years ago by teor

Resolution: fixed
Status: newclosed

Please reopen if the issue reoccurs on the latest Tor Browser version.

Note: See TracTickets for help on using tickets.