Opened 4 years ago

Closed 4 years ago

#16026 closed defect (fixed)

TorBrowser 5.0a1 segfaults on embedded mp4 video due to gstreamer on EL6

Reported by: hiviah Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-crash, tbb-usability-website, TorBrowserTeam201505R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TorBrowser 5.0a1 segfaults if a page has video tag with mp4 source. It's caused by gstreamer.

Example page: http://www.download3k.com/articles/Imgur-Converts-Animated-GIF-Files-To-MP4-Videos-With-GIFV-Format-00783

Workaround:

  1. set media.gstreamer.enabled = false in about:config, or
  1. disable video tag with NoScript

OS/distro notes:

  • EL6 (Scientific Linux 6.6) - segfault
  • Ubuntu 14.04 - seems to disable replay altogether - "MIME type not recognized" (I might be missing the right gstreamer plugins)

Child Tickets

Change History (11)

comment:1 Changed 4 years ago by mikeperry

Is this specific to 5.0a1, or does it also happen with 4.5.1?

comment:2 Changed 4 years ago by hiviah

Happens also with 4.5.1, I just checked.

I think this is the upstream firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1145230

comment:3 Changed 4 years ago by gk

Keywords: tbb-crash tbb-usability-website added
Version: Tor: unspecified

This works for me for Tor Browser on a Ubuntu 12.04 without any crashing. It does not crash my Firefox 38 on a Ubuntu 14.04 either although I can't get the video running neither in Tor Browser nor vanilla ESR 31 there. So, hrm...

Last edited 4 years ago by gk (previous) (diff)

comment:4 Changed 4 years ago by gk

Status: newneeds_information

I have an idea, hiviah, what is your gstreamer version?

comment:5 Changed 4 years ago by hiviah

I experimented with the gstreamer plugins and I think I've found the culprit - it was the gstreamer-ffmpeg package. After removing this package, neither 4.5.1 nor 5.0.a1 crashes anymore.

comment:6 Changed 4 years ago by hiviah

Just for sake of completeness, here is currently installed list of gstreamer* packages (it works with these without segfault):

gstreamer.x86_64                0.10.29-1.el6
gstreamer-plugins-base.x86_64   0.10.29-2.el6
gstreamer-plugins-good.x86_64   0.10.23-1.el6
gstreamer-tools.x86_64          0.10.29-1.el6

comment:7 Changed 4 years ago by gk

Status: needs_informationnew

Thanks this makes sense looking at https://bugzilla.mozilla.org/show_bug.cgi?id=981869#c47

Could you test one of the test builds found on https://people.torproject.org/~gk/testbuilds/16026/ and report back if it fixes your issue?

comment:8 Changed 4 years ago by hiviah

Yes, the testing build fixes the gstreamer crash (even with the gstreamer-ffmpeg installed).

comment:9 Changed 4 years ago by gk

Keywords: TorBrowserTeam201505R added
Status: newneeds_review

comment:10 in reply to:  9 Changed 4 years ago by mcs

Replying to gk:

Thanks, bug_16206 (https://gitweb.torproject.org/user/gk/tor-browser.git/commit/?h=bug_16026&id=7438b5900ba488e9de76ddb8bead1ac407c99730) has the fix for review then.

The patch looks good to me.

comment:11 Changed 4 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Fixed in commit 9b5866c548c768b2a604d43896ce74e2a40848d0 (4.5) and bc455d559db70c2106124492d9aa1e516b63ed52 (5.0).

Note: See TracTickets for help on using tickets.