Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16046 closed defect (duplicate)

Manual HTTP proxy configuration broken?

Reported by: vynX Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have been unable to change the configuration from SOCKS proxy to HTTP proxy. Torbrowser would simply claim there isn't any HTTP proxy answering while telnet confirms there is. Is this a known bug? Is this related to ticket #8511 or #8228? Is this a new one? Is it happening in my implementation only? This bug tracker is so huge, it's hard to figure out.

I'm running the current version, based on FX 31.6.0.450.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by vynX

I had closed this ticket marking it a duplicate of #13786 ... how come it is re-opened and the notice that I had closed it has disappeared? Mysteries of SQL.

comment:2 Changed 5 years ago by vynX

I noticed a barely visible notice on the menu stating that I have to disable Torbutton to be able to change those settings. Going to Torbutton the "Tor Network Settings" item opens no window or anything. I assume that is a bug, possibly of my compile. I have generated torbrowser from tor-browser-31.7.0esr-4.5-1-build1.tar.gz. I am using it with an external Tor router.

Last edited 5 years ago by vynX (previous) (diff)

comment:3 in reply to:  2 Changed 5 years ago by mcs

Replying to vynX:

I noticed a barely visible notice on the menu stating that I have to disable Torbutton to be able to change those settings. Going to Torbutton the "Tor Network Settings" item opens no window or anything. I assume that is a bug, possibly of my compile. I have generated torbrowser from tor-browser-31.7.0esr-4.5-1-build1.tar.gz. I am using it with an external Tor router.

That menu item opens a window that is implemented by the Tor Launcher extension and does nothing if Tor Launcher is not installed. If you are not using tor's proxy, then you probably do not want Tor Network Settings anyway.

comment:4 Changed 5 years ago by mcs

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #13786.

comment:5 Changed 5 years ago by vynX

Ok now I understand what I was missing. In that case however there seems to be no way for me to "disable TorButton" as stated in the Mozilla Preferences. Looks like I need to make myself a torlauncher in order to be able to disable TorButton, still it could be an improvement if TorButton was at least visibly complaining or going on strike whenever torlauncher isn't there. I may not be the last guy to compile Tor Browser from source...

Note: See TracTickets for help on using tickets.