Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1607 closed task (duplicate)

Add code that will make it possible to request bridges for a certain country

Reported by: phobos Owned by: kaner
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: #4380 Points:
Reviewer: Sponsor:

Description

Add code that will make it possible to request bridges for a certain country like so: By mail: bridges+zh@… By http: https://bridges.torproject.org/zh

Child Tickets

Change History (10)

comment:1 Changed 9 years ago by phobos

Component: Tor - DistributionTor - BridgeDB

comment:2 Changed 9 years ago by nickm

Please clarify. Would bridges+zh mean "bridges located in China" or "bridges which we think aren't blocked by China" ? I'm assuming the latter, since I'm not sure what the former would mean.

comment:3 Changed 9 years ago by arma

Yes, the latter.

I'm not sure how we're going to decide what's in which category, but we can sort that out later.

But it means that we need a way to tell bridgedb which bridges count / don't count for a given country.

Also, just as important here is the fact that we know what language to use when answering. We could also take this opportunity to add extra information to e.g. people in China.

One problem that will come up after a while is that languages != countries. So if we have a
bridges+es@… address, what country do we answer for? I think the answer is that we should
think of these as country codes, not languages. That said, it's fine to have lots of synonyms, like both zh and cn.

comment:4 Changed 9 years ago by kaner

Owner: set to kaner
Status: newassigned

As a first step, I'll add code to support the necessary language features and "plus" addresses.

comment:5 Changed 9 years ago by arma

Parent ID: #1608

comment:6 Changed 9 years ago by kaner

The first step (enable BridgeDB to differentiate via "+" email addresses or ?lang=foo http requests) is done in #1613. Please see also: https://trac.torproject.org/projects/tor/ticket/1613

I'm unsure if we should close this bug for now, because the title sure is a bit misleading.

comment:8 Changed 9 years ago by arma

Sounds like #1607 = #1613

It would still be handy to be able to tell people https://bridges.torproject.org/zh rather than https://bridges.torproject.org/?lang=zh

comment:9 Changed 9 years ago by kaner

Resolution: duplicate
Status: assignedclosed

Duplicate of #1613, closing

comment:10 Changed 8 years ago by karsten

Milestone: BridgeDB Upgrades Phase 1
Parent ID: #1608#4380

Assigning as a child ticket to the project ticket that replaces the "BridgeDB Upgrades Phase 1" milestone.

Note: See TracTickets for help on using tickets.